8 Replies Latest reply on Mar 12, 2015 12:55 PM by Peter Spier

    How do I remove a gap between table rows in InDesign?

    sarahc58919 Level 1

      I need help in figuring out how to remove gaps between table rows.  I have tried Table Spacing under Table Set-up, but it doesn't work.

      Here's what I'm working on:gapbetweenrowsjpg.jpg

      As you can see there are gaps above the first row and below last row under the header Business Management Technology.  I cannot select that gap.  How do I remove it, so that the first class, 31058, is flush with the black header?  (and the last class, 32675, is flush with the Chemistry header?)

       

      Any advice would be greatly appreciated.

       

      Thanks,

      Sarah 

        • 1. Re: How do I remove a gap between table rows in InDesign?
          SJRiegel Adobe Community Professional & MVP

          It's hard to tell without seeing the actual file, but it may be that the black bar is created with a paragraph rule instead of cell color. If that's the case, you could fix this by decreasing the row height, or by getting rid of the paragraph rule, and coloring the cells black.

          Screen Shot 2015-03-12 at 12.54.59 PM.png

          • 2. Re: How do I remove a gap between table rows in InDesign?
            John Mensinger Adobe Community Professional & MVP

            It's difficult to tell whether that is all one table, but it does look like the "gaps" are indeed table rows.

            sarahc58919 wrote:

            I cannot select that gap.

            What happens when you try?

             

            If you've only attempted it using the  mouse, I suggest you try it with the keyboard. Click a live cursor into any cell above the gap-row, then tap the TAB key to move the cell selection across/down through the table until it gets to the first cell of the gap-row. If it goes the way I've described, you could then select the entire row using Shift+Rt-Arrow, but it's not necessary. With any number of cells in that row selected, press Ctrl/Cmd+Backspace to delete the row.

            • 3. Re: How do I remove a gap between table rows in InDesign?
              John Mensinger Adobe Community Professional & MVP

              SRiegel wrote:

              ...it may be that the black bar is created with a paragraph rule instead of cell color.

              I hadn't considered that, and your example is proof-of-concept. However, now that you made me look closer, I still don't think that's the OP's case, seeing as the text in the OP's header rows appears to span more than one column, belying what I suppose must be merged cells.* The column strokes in the "gap" appear to disqualify it (the gap) as part of a row with merged cells.

               

              *There is still another possibility that someone "made pictures" of tables with merged cells by overlaying text frames to make the header rows. I've run across all kinds of such "carpentry;" especially when the file may have originated at the desk of someone who avoids or resists use of tables. They find ways to fake them and/or their features.

               

              [still looking]

              • 4. Re: How do I remove a gap between table rows in InDesign?
                SJRiegel Adobe Community Professional & MVP

                Another option that takes into consideration the longer-than-one-cell headlines: If the original creator of the table didn't know about merging cells, they might have put the headline into a black text box, and anchored that into the table row.

                Screen Shot 2015-03-12 at 1.25.29 PM.png

                • 5. Re: How do I remove a gap between table rows in InDesign?
                  sarahc58919 Level 1

                  Hello,
                  I found a "work around" to fix the problem.  I cut all three rows out of the table.  Then I copied rows from under the Chemistry header in their place, and filled in the right data.  So it appears the gaps are linked to the rows, not to the black header:

                  rowswithgap.jpg

                  I don't know if this is helpful in solving the mystery, but it did make it look the way I want it to.

                   

                  Thanks again,

                  Sarah

                  • 7. Re: How do I remove a gap between table rows in InDesign?
                    SJRiegel Adobe Community Professional & MVP

                    I'm glad you found a way to fix it.

                    May I make one suggestion? If you add a little cell padding, it will take your text off of the table lines, and make it easier to read. Just select the cells, and add the numbers in the circled fields.

                    In this example, the top row has it, and the bottom row doesn't. (I have found that tables imported from Excel tend to come into InDesign without any cell padding.)

                    Screen Shot 2015-03-12 at 2.08.46 PM.png

                    • 8. Re: How do I remove a gap between table rows in InDesign?
                      Peter Spier Most Valuable Participant (Moderator)
                      I found a "work around" to fix the problem.  I cut all three rows out of the table.  Then I copied rows from under the Chemistry header in their place, and filled in the right data.  So it appears the gaps are linked to the rows, not to the black header:

                      rowswithgap.jpg

                      I don't know if this is helpful in solving the mystery, but it did make it look the way I want it to.

                      That makes it sound like it might be a nested table (table inside the cell of another table).