0 Replies Latest reply on Feb 10, 2007 4:02 PM by EladElrom

    AS3.0 socket script doesn’t work with flex coldfusion local server

    EladElrom
      I am having a real problem using my script in flex coldfusion project. I tried everything I can to get an answer including posting a question in two groups with no success.

      I created a class that goes and connect through a socket connection and it works fine under “basic” flex project, however when I try to use the package in a flex coldfusion project I keep getting error messages:


      *** Security Sandbox Violation ***
      Connection to domainName.com:60 halted - not permitted from http://localhost:8500/ProjectName/bin/fileName.swf
      Error #2044: Unhandled SecurityErrorEvent:. text=Error #2048: Security sandbox violation: http://localhost:8500/ProjectName/bin/fileName.swf cannot load data from domainName.com:60. At com.elad.as3.socket::socketConnect$iinit()[C:\CFusionMX7\wwwroot\ProjectName\com\elad\as3 \socket\socketConnect.as:14]

      It looks to me that because there are two URL
      http://localhost:8500/ProjectName/bin/fileName. and
      C:\CFusionMX7\wwwroot\ProjectName\com\elad\as3\socket\socketConnect.as

      The player set the security in full effect and I cannot access other servers. I tried everything including setting the security and adding my local server to the approved servers.

      This is a real problem because I will not be able to test my application locally.

      Thanks in advance for the help,