4 Replies Latest reply on Sep 13, 2016 12:02 PM by edgaro21989637

    How do we determine the HTTP authentication header for our hosted solution?

    jcdarulqasim Level 1

      How do we determine the HTTP authentication header (adobeconnect_admin_httpauth) from our hosted solution? The documentation says to find it in a custom.ini file but I have no clue how to access that.

       

      I need to supply that to the adobeconnect plugin used with a Moodle instance, screnshot below.

      adobeconnect.png

       

      If it helps, when I click "Test Connection", I see the following output.

      A series of tests have been run in order to determine whether the Adobe Connect Pro server has been properly setup for this integration to work and to also determine whether the user credentials provided in the activity global settings has the correct permissions to perform the neccessary tasks required by the activity module. If any of the tests below have failed, this activity module will not function properly.

       

      For further assistance and documentation in how to set up your Adobe Connect Pro server please consult the MoodleDocs help page for this activity module Help page

       

      Sending common-info call:

       

      successfully obtained the session key: na11breezrirhb4f4ryf5shqy

       

      successfully logged in as admin user

       

      Testing retrevial of shared content, recording and meeting folders:

       

      error obtaining shared content folder

       

      XML request:

      <?xml version="1.0" encoding="UTF-8"?> <params><param name="action">sco-shortcuts</param></params>

       

      XML response:

      <?xml version="1.0" encoding="utf-8"?> <results><status code="no-access" subcode="no-login"/></results>

       

      error obtaining forced-archives (meeting recordings) folder

       

      XML request:

      <?xml version="1.0" encoding="UTF-8"?> <params><param name="action">sco-shortcuts</param></params>

       

       

      XML response:

      <?xml version="1.0" encoding="utf-8"?> <results><status code="no-access" subcode="no-login"/></results>

       

      error obtaining meetings folder

       

      XML request:

      <?xml version="1.0" encoding="UTF-8"?> <params><param name="action">sco-shortcuts</param></params>

       

      XML response:

      <?xml version="1.0" encoding="utf-8"?> <results><status code="no-access" subcode="no-login"/></results>

       

      error creating meeting testmeetingtest folder

       

      XML request:

      <?xml version="1.0" encoding="UTF-8"?> <params><param name="action">sco-update</param><param name="type">meeting</param><param name="name">testmeetingtest</param><param name="folder-id"/><param name="date-begin">2015-03-14T06:53:39.000+00:00</param><param name="date-end">2015-03-14T07:53:39.000+00:00</param></params>

       

      XML response:

      <?xml version="1.0" encoding="utf-8"?> <results><status code="invalid"><invalid field="folder-id" type="id" subcode="format"/></status></results>

       

      error creating user testusertest

       

      XML request:

      <?xml version="1.0" encoding="UTF-8"?> <params><param name="action">principal-update</param><param name="first-name">testusertest</param><param name="last-name">testusertest</param><param name="login">testusertest@test.com</param><param name="password">9B396EA828A00203FB3E8E69010FE537</param><param name="extlogin">testusertest@test.com</param><param name="type">user</param><param name="send-email">false</param><param name="has-children">0</param><param name="email">testusertest@test.com</param></params>

       

      XML response:

      <?xml version="1.0" encoding="utf-8"?> <results><status code="no-access" subcode="no-login"/></results>

       

      What are we missing?

       

      Thanks!