1 Reply Latest reply on Feb 8, 2007 12:01 PM by MrMetlHed

    Builder Source Path Not Functioning Properly

    MrMetlHed
      I'm trying to get the Flex / Ajax Bridge to work, so I added a build path to my project (right click on Project, click Build Path, click Source Path, target the src folder of the FABridge.as file, and okay all of that).

      My current source path as shown in Flex Builder is: ${DOCUMENTS}\FABridge_B4_013007\src (I've tried one level up from that as well).

      Whenever I try to compile a very, very simple application that looks like this:

      <?xml version="1.0" encoding="utf-8"?>
      <mx:Application xmlns:mx=" http://www.adobe.com/2006/mxml" layout="absolute"
      xmlns="*" xmlns:qs="qs.containers.*">
      <fab:FABridge xmlns:fab="bridge.*" />
      </mx:Application>

      I keep getting the error: "Could not resolve <fab:FABridge> to a component implementation."

      I also get this error trying to use any other component that's not in the main source directory of the project.

      The weird part is that I can type "import bridge.FABridge" within a script block and get all the autocomplete help, but the thing still won't compile.

      Am I missing something stupid? I've tried everything from using Flex Builder (2.0.1) as an Eclipse Plug-in, and uninstalling / reinstalling everything.