10 Replies Latest reply on Feb 9, 2007 1:45 PM by JohnGree

    page refresh

    JohnGree Level 1
      Hi is it possable to refresh a page every 60 seconds, if so who would i do this
        • 1. Re: page refresh
          joeDangelo Level 1
          Just add this to the <head> section of your HTML document
          • 2. Re: page refresh
            JohnGree Level 1
            Hi i am using <meta http-equiv="refresh" content="60" />
            but this refreshs the page even if i am on another page of the website, so i get constant clicking of a page refreshing

            what i want is, if a user is only on the page which has the refresh code on then it refreshes, so it must not refresh if i am only a different page ie if the refresh is on the home page and i click to goto the aboutus page, while i am on the aboutus page i can here the page still refreshing?
            • 3. Re: page refresh
              azadisaryev
              please clarify your problem:

              where do you have the <meta http-equiv="refresh" content="60" /> code? is it in individual pages or in some header.cfm which is cfincluded in all pages?

              do you mean that when you open another page in a new browser tab/window the old page keeps refreshing or that the new page keeps refreshing when you open it in the same tab/window (replacing the old page)?

              it sounds like you have the refresh meta tag in some sort of cfincluded document which is included in every page...
              • 4. Re: page refresh
                JohnGree Level 1
                ok if you go to http://www.southerncooling.com/SmallNetOrders.cfm

                this page has a refresh on it, then click view, this page has no refresh or cfinclude, and in the status bar at the bottom it shows the previous page refreshing?
                • 5. Re: page refresh
                  azadisaryev Level 1
                  i just checked your page in Firefox using "View Generated Source" from the WebDeveloper extension, and this is the first line in the source:

                  <html><head><meta http-equiv="REFRESH" content="60; url=http://www.southerncooling.com/SmallNetOrders.cfm">
                  • 6. Re: page refresh
                    azadisaryev Level 1
                    oops... checked a wrong page...
                    now checked the View page, and in Firefox it does not refresh and does not show anything in the statusbar... are you sure it is not your browser's chache playing tricks with you?
                    • 7. page refresh
                      JohnGree Level 1
                      ok that example didnt work how i was veiwing it .

                      if you look at http://www.southerncooling.com/test.cfm

                      and make sure you click on one of the view links, the next page is refreshing the previuos page when it has no refresh on
                      • 8. page refresh
                        JohnGree Level 1
                        ok its not the cache i just tested it, if you do these steps from this link you should see what is happening

                        http://www.southerncooling.com/test.cfm

                        1. wait for the atuo refresh on the test.cfm
                        2. click on the view link
                        2. wait for 60 secs you will see the previous page refresh in status bar
                        • 9. Re: page refresh
                          jdeline Level 1
                          I'm using IE 6.0 and followed the three steps you outlined. When got to the page by way of the VIEW link and waited 60 seconds, there was no refresh. This is what I would expect since the test.cfm and corresponding IFrame smallNetOrders.cfm are closed when VIEW is clicked.

                          Have you tried removing the metatag from the IFrame and placing it in test.cfm?

                          What browser and version are you using?
                          • 10. Re: page refresh
                            JohnGree Level 1
                            yes excatly thats what i thought!!

                            i am using 6.0 as well, why would i be getting this?