6 Replies Latest reply on Mar 19, 2015 8:36 PM by rickr29996902

    Lightroom loses files on a Network Attached Storage (NAS) drive

    rickr29996902

      I am using Lightroom 5.7 on a PC in Windows 7 64-bit.

       

      A couple of weeks ago I installed a Network Attached Storage (NAS) system as I was running out of internal hard disk space.  I set up a logical drive on the NAS for Photos.  In Lightroom, I dragged the photo files over onto the new drive.  The catalogue and backup files remained on the internal hard drive.

       

      My photos are arranged chronologically, in directories (years) and subdirectories (days, named using the format "2014_12_31").

       

      Since moving the files to the NAS, Lightroom has been giving me error messages when in the Develop module that it cannot find files.  The previews view fine in the Library module, and the files are still there when I look for them in Windows Explorer.  The errors do not occur within entire directories (years) subdirectories (days) - only some files within individual subdirectories are affected.  And, only files from 2015 seem to have the problem.  And, when I drag the directories back to my internal hard drive (again, within Lightroom), the errors disappear and everything works fine.

        • 2. Re: Lightroom loses files on a Network Attached Storage (NAS) drive
          rickr29996902 Level 1

          The article you referred me to was very helpful.  I feel a bit silly that the solution was that simple, but hey, problem solved.  Thanks!

          • 3. Re: Lightroom loses files on a Network Attached Storage (NAS) drive
            rickr29996902 Level 1

            Ok, well, thought we had the problem solved, but not so.  I followed the suggestions in the article - using the "Update Folder Location" command that comes up with a right click on each folder.  This seemed to work well.....at first.

             

            Looking back through some of the folders for each year, I am again getting the error message "The file could not be found" when I open the Develop module.  The preview is there, the file is physically on the disk where it is supposed to be - but clearly the connection between the preview and the raw file is broken.  This occurs only in some subfolders, not all subfolders within each year folder.  Updating the folder location does not fix the issue.  And, there is no "?" on the folder or "!" on the individual photos within the library view indicating the file associations are broken.  With no "!" in library view on each file, there is no option given to try to find individual photos (but there are too many of them affected to do that anyway, so that point is moot).

             

            This is very frustrating.  Is it possible there is something about the way lightroom is accessing the raw files on the NAS, that the links get broken and won't re-establish?  The NAS is a Syncology DS415+, with 4 X 2 TB WD hard drives set up in a hybrid RAID configuration.  I am running Windows 7 on a PC, with Lightroom version 5.7.

            • 4. Re: Lightroom loses files on a Network Attached Storage (NAS) drive
              dj_paige Level 9

              So, in Lightroom, for one of these "problem" files, right-click on it and select Show in Finder (Mac) or Show in Explorer (Windows). Does that locate the proper photo in Finder or Explorer?

              • 5. Re: Lightroom loses files on a Network Attached Storage (NAS) drive
                rickr29996902 Level 1

                Yes, right clicking on the problem folders and showing in explorer does show the connection is to the correct folder location.

                 

                A couple more points that may be worth mentioning:

                 

                When I was having this problem earlier this week, the missing photos seemed to be spread randomly within different folders and subfolders (folders are year, with subfolders for each day I have photos).  I followed the advice in the document you referenced yesterday, and went back through each main folder (there are about a dozen of them, one for each year plus a few miscellaneous folders) and used the "update folder location" function.  This worked well I thought - except I realized later on that one year (2014) still had the photos missing - but this time, it seems to be all photos within that year folder, not just a few random ones.  There is no "?" on the folder, or "!" on the individual photos, they show fine in preview, but clicking on the develop module every photo has the message "cannot find file".  When I right click on the folder, or individual files to follow the location of the file in explorer, the location is correct - and as far as I can tell the locations and structure is consistent with the folders for all the other years which Lightroom has no problem finding.  That is, I can see nothing "unusual" about the folder for 2014 in the way it sits within my filing structure.

                 

                And here's the kicker - last night I made a copy of the entire 2014 folder that was on the NAS external drive (where Lightroom can't seem to locate the files) back on to my internal drive (this took a couple of hours).  This morning, I forced Lightroom to lose the link to the folder on the network drive by simply changing the name of the folder from within windows explorer, and then the "?" and "!" warnings popped up in Lightroom indicating it could not find the folder and files.  I then used "update folder location" to point Lightroom at the copies that were now on the internal drive, and the problem disappeared (all files were located).

                 

                Finally, I then broke the link to the folder on the internal drive by changing the name of the folder on the internal drive from within explorer, renamed the folder on the NAS drive back to "2014", then opened up Lightroom again (and of course it indicated the files were missing) and used the update feature again to point Lightroom back to the folder on the NAS.  And, again, the missing files errors pop up for every photo within that folder - but no "?" or "!" warnings are shown  (recall these are an exact copy of the files that it had no trouble finding on the internal drive).

                 

                I tried playing various games with Lightroom last night, forcing it to break linkages by renaming folders, etc, and every time when I use the update file location feature it has no trouble reconnecting, whether the folders are on my internal drive or the NAS.  So, this functionality seems to be working within Lightroom and I know how to use and abuse it. BUT, it steadfastly refuses to reconnect with the 2014 folder when it's on the NAS, but has no trouble reconnecting when pointed to an exact copy of the same folder on my internal drive.

                 

                I'm kind of at my wits end here.  There seems to be some sort of bug in Lightroom that makes it lose it's wits when connecting to photos on a NAS drive.  Or, I'm doing something really wrong that isn't obvious......

                • 6. Re: Lightroom loses files on a Network Attached Storage (NAS) drive
                  rickr29996902 Level 1

                  It's possible I may have found the problem (so far, so good).

                   

                  There is a function in Windows 7 that builds offline files that can be accessed when a network storage drive is offline.  This was new to me as up until a couple of weeks ago I never had a NAS at home.  It is accessed through the "Sync Center".

                   

                  Somehow, while setting up the NAS a couple of weeks ago and migrating my photo files over to the new network drive, "Make Available Offline" got enabled for some of my photo folders, but not all.  Right clicking on the photo folders within explorer, opening up the Properties menu, and then un-clicking the option for making files available offline - then also disabling this feature, plus deleting all the offline files (don't quite recall where this was located) seems to have fixed the problem.

                   

                  Not an obvious solution.  And not really related to Lightroom, but Windows.  Since I couldn't find this particular problem anywhere on the forum, it might be worth the forum keepers capturing it somehow....but I'll leave that up to you.

                   

                  Fingers crossed, but hoping I have no more issues with this problem.