5 Replies Latest reply on Mar 19, 2015 6:13 PM by J Isner

    ctrl-E launches wrong version of Photoshop CC

    J Isner Level 1

      I have Photoshop CC 2014 as well as Photoshop CC installed on my Windows 7 computer.  I should probably have uninstalled Photoshop CC 2014 because I only use Photoshop CC. But I did not, and now I have a mysterious problem.

       

      I launch Photoshop from Lightroom 5.7 using ctrl-E or an equivalent menu entry.  It has always launched Photoshop CC.  Tonight, for the first time, Lightroom launched Photoshop CC 2014!  I could tell immediately that something was wrong because of the way my Photoshop workspace was configured.  It was configured differently from how I had left it when I last exited Photoshop.   Help -> About Photoshop confirmed that the version that Lightroom had launched was Photoshop CC 2014.2.2.

       

      Back in Lightroom, I checked Edit -> Preferences -> External editing tab:

      Lightroom Edit Preferences External Editing tab.jpg

       

      I don't want Lightroom to edit in Photoshop CC 2014.  I want it to edit in Photoshop CC, but I don't see a way to tell Lightroom to change this preference.

       

      I tried exiting from Lightroom and restarting, but this did not fix the problem.  Lightroom still launches the wrong version of Photoshop.

       

      FYI I have not installed any Adobe updates recently or done any reconfiguring Windows.  I use Lightroom and Photoshop daily.


      EDIT: If Photoshop CC is already running when I launch Lightroom and ctrl-E a photo, the photo is opened in the version of Photoshop that is already running.  Good!  But if Photoshop is NOT running and I ctrl-E a photo in Lightroom, Photoshop CC 2014 is launched.  NOT GOOD!  But at least I have a temporary workaround.

        • 1. Re: ctrl-E launches wrong version of Photoshop CC
          ManiacJoe Adobe Community Professional

          It would appear that by default LR is going to launch the most recent version of PS you have installed.

          The workaround that you have found would be the solution for running an older version of PS, short of uninstalling PS 2014.

          • 2. Re: ctrl-E launches wrong version of Photoshop CC
            J Isner Level 1

            @ManiacJoe your explanation makes perfect sense.  When CC releases a new version of Photoshop, they release both CC and CC 2014.  I probably installed PSCC then PSCC 2014, making it the most recent version installed.  I didn't notice the problem until now because either I have been running PSCC continuously or because I launch PSCC before launching LR.  It may also be that I didn't notice the DIFFERENCE between PSCC and PSCC 2014 until I reconfigured my workspace in PSCC.  I think the correct solution (for me) would be to uninstall PSCC 2014 because I never use it.  Thank you for your help!

            • 3. Re: ctrl-E launches wrong version of Photoshop CC
              J Isner Level 1

              To prevent this problem from happening in the future, I uninstalled Photoshop CC 2014.  I did this using the Creative Cloud Desktop app, which not only uninstalls the program on Windows but also changes its status on the Adobe server.

               

              After the uninstall, the folder C:\Program Files\Adobe\Adobe Photoshop CC 2014 was empty except for the plugins directory.  So far, so good.

               

              I launched Lightroom and checked the External Editing preferences.  It now shows this (good):

              Image.png

              I selected a file in Lightroom and did Photo -> Edit in -> Edit in Adobe Photoshop CC (ctrl-E).  Photoshop CC launches (good).

               

              But now the problem: The file does not open!

               

              I repeated the experiment with Photoshop CC already running.  Same result: the Photoshop window comes forward to the top of the desktop window stack, but the file does not open.

               

              It looks like Lightroom is still sending the file down the wrong pipe because it's not getting to Photoshop.

               

              Any idea of what's happening here?  Meanwhile, I will reboot Windows and see if that clears up the problem.

              • 4. Re: ctrl-E launches wrong version of Photoshop CC
                J Isner Level 1

                Rebooting Windows did not solve the problem.  ctrl-E in Lightroom continues to send files into the void.

                • 5. Re: ctrl-E launches wrong version of Photoshop CC
                  J Isner Level 1

                  I keep adding replies because the forum is not allowing me to edit my previous posts.

                   

                  I discovered that ctrl-E works for psd's, tifs, and jpegs, but not for raw files.  ctrl-E constently fails to send the file to Photoshop CC for edit.  I have tried with a variety of dng's, nefs, and cr2's and the result is always the same: the file simply does not show up in Photoshop CC (although the Photoshop window comes to the fore, as if expecting to receive a file).