1 Reply Latest reply on Feb 16, 2007 8:15 AM by

    Compiler Shell Error

    sdafa weertaw4trq24 Level 1
      I can get the example I have to compile on its own (just a label inside an application):

      mxmlc c:/Workspace_IDE/flex/samples/shell/shell.mxml

      but when I try within the shell it gives me this error:

      (fcsh) mxmlc c:/Workspace_IDE/flex/samples/shell/shell.mxml
      fcsh: Assigned 1 as the compile target id
      Loading configuration file C:\Workspace_IDE\FlexIDE\Flex SDK 2\frameworks\flex-c
      onfig.xml
      Error: flex2.tools.API.checkSupportedTargetMimeType(Lflex2/compiler/io/VirtualFi
      le;)V

      java.lang.NoSuchMethodError: flex2.tools.API.checkSupportedTargetMimeType(Lflex2
      /compiler/io/VirtualFile;)V
      at flex2.tools.SimpleShell.mxmlc(SimpleShell.java:731)
      at flex2.tools.SimpleShell.process(SimpleShell.java:117)
      at flex2.tools.SimpleShell.main(SimpleShell.java:63)
      (fcsh)

      This is the first time I am trying to use the shell, and I have tried this on two computers with the same result.

      Thanks for any help.
        • 1. Re: Compiler Shell Error
          Have you tried compiling just using mxmlc instead of the compiler shell (fcsh)? Is it possible that you have an older version of the compiler installed on your machine?... is it possible that you have a combination of 2.0 and 2.01 on your machine?

          -brent