0 Replies Latest reply on Jan 30, 2007 10:40 AM by macsavers

    Safari Issue with loadMovie

    macsavers Level 1
      Okay, I'm frustrated.

      I'm using a very simple actionscript to try and test loading external graphics, which I need for a project. It works in the Flash Player and in Firefox, but Safari seems to ignore the loadMovie command.

      Here's the actionscript: loadMovie("first.swf", "first_swf");

      This is actually from a tutorial from FlashKit, so I'm sure it worked for the person who made this, but they didn't have Safari most likely. The instance name is there and the movieclip is there, but Safari is refusing to see the external file it seems.

      Any suggestions? I'm using OS X 10.4.8 with Safari 2.0.4 (419.3) with Flash 8.

      P.S. Strange as it may sound, I went ahead and uploaded the movie and the first.swf file to my web server and tried it over the web and it worked just fine. It just won't work in a drap and drop from my computer into the browser. So, while this isn't critical now, it is strange that the OS X file system is being ignored on the loadMovie command, but it works via the web and HTTP call.