4 Replies Latest reply on Jan 31, 2007 7:49 AM by HKabaker

    Preview not working

    maniac9999 Level 1
      Hey everyone,

      A colleague of mine reported that her "Preview" option suddenly stopped working the other day. I saw it at her desk - it doesn't give her an error, it just doesn't work. She's using RH X5.02, building WebHelp.

      I'm thinking this might require a reinstall of RH X5 on her PC, since it's happening to all of her projects.

      What do you think? Any ideas?

      Thanks,
      Jim
        • 1. Re: Preview not working
          Peter Grainge Adobe Community Professional (Moderator)
          Before you do that, search the forum. I'm pretty sure RoboWizard has covered that one in recent months.

          • 2. Re: Preview not working
            maniac9999 Level 1
            Peter,

            I tried searching on "Preview" 'Preview Error" "Preview Doesn't Work", etc, without any luck. Any idea which sub forum I should look in? I also went to robowizard.com and couldn't find anything there.

            Jim
            • 3. Re: Preview not working
              Captiv8r Adobe Community Professional & MVP
              Hi Jim

              This would indicate the screen coordinates went walkabout on your colleague's PC. Unfortunately, I'm guessing that even a reinstall won't help. Sooooo, here goes!

              Topic Preview Window missing in action

              Symptom


              When selecting the Topic Preview (eyeglasses) toolbar button, pressing <Ctrl>+W, or selecting View > View (topic title), the preview window never appears.

              What has happened

              I haven't a clue as to how this occurs, but I occasionally see posts about this in the forums. Somehow, the screen coordinates for the missing window have become set to your computer's equivalent of Jupiter. (I used to say "Pluto" here, but alas, they demoted the poor little guy from planet status) The window is indeed there. However, it's been moved off the visible area of the screen.

              How to correct it

              Close RoboHelp HTML.

              You need to do this because the values we are about to change will be destructively changed once we close RoboHelp HTML and restart.

              Open the Windows Registry Editor.
              (All standard disclaimers apply. Back up the registry, sacrifice a chicken, yadda yadda yadda)

              Locate the following key:
              HKEY_CURRENT_USER\Software\version\RoboHTML\version\MontereyFrame\

              Double click the item labeled Preview in separate window and ensure the value is set to 1. If it already is, terrific. If not, change it to 1 and click the OK button. It doesn't matter if the option is set to Hex or Decimal.

              Double click the item labeled PreviewMaximized and ensure the value is set to 0. If it already is, terrific. If not, change it to 0 and click the OK button. It doesn't matter if the option is set to Hex or Decimal.

              Double click the item labeled PreviewWindowCX. Make sure the option is set to Decimal and set the value to 50. Then click the OK button.

              Double click the item labeled PreviewWindowCY. Make sure the option is set to Decimal and set the value to 50. Then click the OK button.

              Double click the item labeled PreviewWindowX. Make sure the option is set to Decimal and set the value to 50. Then click the OK button.

              Double click the item labeled PreviewWindowY. Make sure the option is set to Decimal and set the value to 50. Then click the OK button.

              Close the Windows Registry Editor.

              Restart RoboHelp HTML and preview a topic.

              The window should now be floating above the RoboHelp HTML application in full view.

              Hopefully that helps... Rick
              • 4. Re: Preview not working
                HKabaker Level 2
                Just a thought --

                If you go to the control panel for "Display" (might be different in XP) and increase screen settings to the maximum (zooming out to the limit), is the preview visible?

                Or, as Rick suggests, are the coordinates totally gone?

                Harvey