3 Replies Latest reply on May 9, 2006 4:13 PM by Newsgroup_User

    template pages won't update

    kapowd
      Hi,
      I am making a website for somebody and for now I am looking at it in a folder on my site. I am having trouble with the template pages not updating when I make changes to the template. Would it be because I have a folder named Template in my site and another one within the folder where the other site is? If so, how can I fix it?

      Thank you,

      Charley
        • 1. Re: template pages won't update
          Level 7
          Here are six ways to make changes not propagate from Template to child -

          1. Rename the Templates folder
          2. Move the Templates folder to some other folder level in the site other
          than root level
          3. Move a template out of the Templates folder.
          4. Make changes to an editable region of the template (which will not
          propagate)
          5. Assume that template changes can be uploaded to the server without also
          uploading the changed local files
          6. Corrupt the site cache so that the link between template and child page
          is broken

          The latter problem can be repaired by using SITE | Advanced > Recreate Site
          Cache, and the five others can be fixed by just not doing them. Have you
          done any of those?


          --
          Murray --- ICQ 71997575
          Adobe Community Expert
          (If you *MUST* email me, don't LAUGH when you do so!)
          ==================
          http://www.dreamweavermx-templates.com - Template Triage!
          http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
          http://www.dwfaq.com - DW FAQs, Tutorials & Resources
          http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
          ==================


          "kapowd" <webforumsuser@macromedia.com> wrote in message
          news:e3r0p5$9md$1@forums.macromedia.com...
          > Hi,
          > I am making a website for somebody and for now I am looking at it in a
          > folder
          > on my site. I am having trouble with the template pages not updating when
          > I
          > make changes to the template. Would it be because I have a folder named
          > Template in my site and another one within the folder where the other site
          > is?
          > If so, how can I fix it?
          >
          > Thank you,
          >
          > Charley
          >


          • 2. Re: template pages won't update
            kapowd Level 1
            Thank you. Yeah, I think so. My website has a Folder named Template in the root level. In order to see the site I am trying to build on my site, I moved the whole thing into a new folder on my site. So, within the new folder is another Template folder. I have been moving the templates back and forth a little to try to trouble shoot. Did I make a mess?
            Could I put the templates from both sites in one template folder at the root level of my site?
            • 3. Re: template pages won't update
              Level 7
              > Did I make a mess?

              A bit, yes.

              > Could I put the templates from both sites in one template folder at the
              > root
              > level of my site?

              This is not going to work with DW. Each site needs its own root folder, and
              its own Templates folder therein.

              --
              Murray --- ICQ 71997575
              Adobe Community Expert
              (If you *MUST* email me, don't LAUGH when you do so!)
              ==================
              http://www.dreamweavermx-templates.com - Template Triage!
              http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
              http://www.dwfaq.com - DW FAQs, Tutorials & Resources
              http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
              ==================


              "kapowd" <webforumsuser@macromedia.com> wrote in message
              news:e3r289$big$1@forums.macromedia.com...
              > Thank you. Yeah, I think so. My website has a Folder named Template in
              > the
              > root level. In order to see the site I am trying to build on my site, I
              > moved
              > the whole thing into a new folder on my site. So, within the new folder
              > is
              > another Template folder. I have been moving the templates back and forth
              > a
              > little to try to trouble shoot. Did I make a mess?
              > Could I put the templates from both sites in one template folder at the
              > root
              > level of my site?
              >