3 Replies Latest reply on Feb 8, 2007 10:39 AM by c_reed

    adobe quiz component issue

    jeff@dadabase.net Level 1
      I have created a quiz movie, it loads each quiz as a swf, within the main movie shell.
      my problem is that i created one of the three quiz types using the flash quiz component. when i click on next question in takes me to frame two in the shell movie rather than in itself. i dont have time to rebuild them all -- the two best solutions i can think of are -----

      1) to convert the individual fla files to symbols - this doesnt work for me as when i selct all the elements only parts are changed to the symbol - the action script part doesnt convert and some other parts

      2) fix the code in the fla so that it works when loaded into the movie as a swf file - i have looked at it but this seems beyond my coding knowledge

      can any one help help me with either of these options or suggest an alternative route thanks
        • 1. Re: adobe quiz component issue
          jeff@dadabase.net Level 1
          can anyone tell me what i am looking at here ? this is the nav code in the link button in the flash quiz component - i have exported the movie as an swf but when i load it into another movie the button goes to a frame in the shell and not the frame in the loaded movie - can anyone help me to edit this so it will refer to the its own movie
          thanks

          ----------------------------------------------------------------


          onClipEvent (load) {
          curQuest = 0;
          if(_parent.Options.QuestionsToAsk < (_parent._totalframes-2) && _parent.Options.QuestionsToAsk > 0){
          totQuest = "/ " + (_parent.Options.QuestionsToAsk+1);
          }
          else{
          totQuest = "/ " + String(_parent._totalframes-1);
          }

          function updateFrame() {
          curQuest++;
          }
          updateFrame();
          }
          • 2. Re: adobe quiz component issue
            jeff@dadabase.net Level 1

            on advice i tried the following, but it hasnt helped - though i think it is in the right direction

            onClipEvent (load) {
            curQuest = 0;
            if(this.nineteen.Options.QuestionsToAsk < (this.nineteen._totalframes-2) && _parent.QuestionsToAsk > 0){
            totQuest = "/ "+(this.nineteen.Options.QuestionsToAsk+1);
            }
            else{
            totQuest = "/ "+String(_parent._totalframes-1);
            }

            function updateFrame() {
            curQuest++;
            }
            updateFrame();
            }
            • 3. Re: adobe quiz component issue
              c_reed
              try this, in each quiz movie on the first frame add:
              this._lockroot = true;