6 Replies Latest reply on Mar 29, 2015 3:36 PM by mbeast42

    0 Photos showing in LR Mobile when collection contains photos

    mbeast42

      Hello all!

      I have been battling and debugging this for over a week now. Any help or guidance would be greatly appreciated.

       

      The issues:

      1. Long (30 - 60 second) pauses entering a collection before anything is displayed.

      2. "0 Photos" displayed in collections that actually contain photos

       

      Details:

      1. When I tap into a collection, there is a very long pause of about 30 seconds, then the thumbnails appear. The collections that exhibit this behaviour appears to be rather random but it does appear that the pauses seem to be upon entering any fifth or sixth collection meaning entering the first four or five collections shows the thumbnails immediately. The collections that pause can have 1 photo in them, or thousands. This behaviour is consistent whether I'm online, or offline. Finally, relating to the second issue, the pause happens consistently on collections listed with "0 Photos" AND collections that display the proper number of photos. Might be related to "0 Photos", but it does happen on other collections as well.

       

      2. Many of my collections now display "0 Photos" when they actually have photos. Upon tapping into them, there is a pause (issue 1 above), then the thumbnails are displayed, then, exiting to the collections view, the proper number of photos is displayed. This behaviour is consistent whether I'm online or offline.

       

      I've been using LR for years and LR Mobile since it came out. I currently have 159 collections with 16,851 photos on my iPad. These issues seemed to appear after the latest IOS update to 8.2 which I did last week. I'm using LR Mobile every few days, sometimes for showing photos, sometimes for editing.


      Things I have tried over the last week (all with no resolution of the issues):

      1. Trimming down the number of collections and photos. I did have about 190 collections and over 21,000 photos and of those about 15,000 available for Offline Editing. LR Mobile was using 21GB on my iPad. It's now (after re-install) using 1.6GB.

      2. Removing LR Mobile (and all local photos of course) and re-installing.

      3. After re-installing, NOT flagging any collections for Offline Editing. I now have one collection with 942 photos downloaded for offline editing as a "control" for debugging these issues.

      4. Installing LR Mobile on my Android (Galaxy SIII). It's perilously slow, but does NOT exhibit the issues.


      I have access to my wife's iPad mini and will be testing on hers to see if the issue might be related to my iPad and not LR Mobile.


      Stats: LR Mobile v 1.3.2 currently using 1.6GB (app and data)

      iPad Mini 64GB IOS 8.2 currently 26GB free


      Thanks,

      Michael

        • 1. Re: 0 Photos showing in LR Mobile when collection contains photos
          greule Adobe Employee

          Have you tried to restart your device. It could be that your device is running low on memory.

           

          Could you send me a LR Desktop diagnostig log  - best as a private message with a downloadable dropbox link.

           

          You can trigger the log via LR Desktop preferences -> Lightroom Mobile and when you hold down the alt key you will notice a generate diagnostic log button.

           

          Btw. When you open up this little cloud indicator within LR Mobile collection view, is there still sync progress showing up? Which version is your iPad Mini? Retina?

           

          Thanks,

          Guido

          • 2. Re: 0 Photos showing in LR Mobile when collection contains photos
            mbeast42 Level 1

            Hi!

            Yes, I've tried rebooting the iPad. No effect. (although I'll try rebooting right now again and let you know the results). I don't use the iPad for much else besides email and a little browsing. It's primarily for LR Mobile.

            I will send the LR Desktop log this evening when I get home. That won't show you what's happening on the iPad, will it? Just desktop to cloud, and any updates that might have originated from the iPad, right? I can also trigger an update from the iPad if you'd like and let that sync to the Desktop happen so you can see it in the logs.

            As for the cloud indicator - I've waited for all syncs to be done. No pending updates from the desktop, and the issues occur with no pending updates from the iPad.

            I just tested as well: cloud indicator when the "pause" is occurring, reports "All up to date" (or "paused" if I'm offline).

            And I have an iPad Mini 2, which has the Retina display resolution.

            Thanks,

            Michael

            • 3. Re: 0 Photos showing in LR Mobile when collection contains photos
              mbeast42 Level 1

              hi,

              Did you get the message with the log? Just want to make sure - the messaging interface was a little confusing.

              Thanks!

              Michael

              • 5. Re: 0 Photos showing in LR Mobile when collection contains photos
                mbeast42 Level 1

                Good morning Guido,

                 

                Well, I may have messed things up, or I may have stumbled across the source of my original issues of "0 Photos" and heavy pauses opening mobile collections.

                 

                I un-synced every collection in LrD. But Adobe online (lightroom.adobe.com) still shows all of the collections. I deleted LrM on my iPad and it's still syncing all the original collections.

                 

                How do I do a complete reset of LrM and all synced collections? I want to start from scratch - nothing sync'd, no collection on Adobe online. I'll remove LrM and start on the iPad from scratch. But only when Adobe online shows what I have flagged for sync in LrD. Then I'll start with a few small collections and see if the original problems persist.

                I'm hesitant to delete the collections on the Adobe site but it seems that that might be the way to go.

                 

                Your help is appreciated.

                 

                Have a great day,

                Michael

                • 6. Re: 0 Photos showing in LR Mobile when collection contains photos
                  mbeast42 Level 1

                  Hi! Me again!

                  Apologies for so many messages.

                   

                  I have been tinkering and researching and found the "Delete all data" button on LrD. I have pressed it.

                   

                  I think this is what I needed to do to reset everything on my iPad.

                   

                  I am now syncing a limited number of collections (23) containing a total of around 300 images. This should be enough to test if the original problems persist.

                   

                  Stay tuned (unless you have any words of wisdom to offer!) and I'll let you know how my testing goes and what the results are.

                   

                  Have a great day,

                  Michael