1 Reply Latest reply on Mar 26, 2015 10:48 PM by johnrellis

    How do I prevent the import of parent keywords?


      Lightroom 5 is adding parent keywords as well as nested/expected keywords during import.


      New to Lightroom, having used Bridge for all my keywording.


      Example photo's keywords:


      "Cottage" - Which in BR was nested in following hierarchy: Places > houses > cottage

      "Canada" - Which in BR was nested in the following hierarchy: Places > Countries > Canada

      "1910" - Which in BR was nested in following hierarchy: Date > Year > 1910s > 1910


      In the BR keyword tree, I have confirmed that only the intended keywords are checked; the parent keywords are not checked.  Also confirmed via the file system these are the only keywords.


      When i import this into LR, the Keywording panel (Will Export) shows the photo has gained the intended/nested keywords PLUS those of its parents from the hierarchy:


      1910, 1910s, Canada, Countries, Date, Date - Year, Places, Year, cottage, houses


      Is there a way to prevent LR from applying the keywords from the hierarchy?  I only want the single keywords to be imported and applied during export. This is just an example, my BR keyword list has 1000's of keywords nested across multiple hierarchies.

        • 1. Re: How do I prevent the import of parent keywords?
          johnrellis Most Valuable Participant

          From what you've posted, it sounds like the photos' metadata actually contains the hierarchical keywords from Bridge (e.g. Places > Countries > Canada). When you import these photos into LR, they are importing as hierarchical keywords, e.g. Places > Countries > Canada rather than just Canada.


          You can confirm that by looking at the Keyword List panel on the right-hand side of Library mode -- you should see the hierarchy of keywords, rather than a flat list of top-level keywords.


          You see the parent keywords like Countries and Places in the Keyword panel (Will Export) because by default LR will include those keywords when you export the photo. If you don't want those parent keywords exported, you can edit each one by right-clicking it in the Keyword List panel, choosing Edit Keyword, and deselecting the option Include On Export.