3 Replies Latest reply on Jan 24, 2007 1:25 PM by serik.george

    Help with some movie clips and an function...

    serik.george
      Hi all..
      I`m having trouble with an function used to animate two movie clips....
      I want to use the function like this " fSwitch("movie1", "movie2"); "

      I`ve checked to see if I had typoes but I don`t and the scripting looks good to me...

      In spite of this fact , when I test the code or movie i get this erros :

      ----------------------------------------------------------------------------------
      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 32: There is no property with the name '_x'.
      sItem2._x = 10;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 33: There is no property with the name '_y'.
      sItem2._y = 10;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 34: There is no property with the name '_xscale'.
      sItem2._xscale = 10;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 35: There is no property with the name '_yscale'.
      sItem2._yscale = 10;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 36: There is no property with the name '_alpha'.
      sItem2._alpha = 0;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 37: There is no property with the name '_y'.
      while(sItem2._y <= Stage.height/2 -1) {

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 38: There is no property with the name '_alpha'.
      if(sItem2._alpha <= 97) {

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 39: There is no property with the name '_alpha'.
      sItem2._alpha += 3;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 40: There is no property with the name '_alpha'.
      sItem1._alpha -= 3;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 42: There is no property with the name '_x'.
      sItem2._x +=2;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 43: There is no property with the name '_y'.
      sItem2._y +=1;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 44: There is no property with the name '_x'.
      sItem1._x +=2;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 45: There is no property with the name '_y'.
      sItem1._y +=1;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 48: There is no property with the name '_y'.
      if(sItem2._y >=98) {

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 50: There is no property with the name '_xscale'.
      sItem2._xscale +=1;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 51: There is no property with the name '_yscale'.
      sItem2._yscale +=1;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 53: There is no property with the name '_xscale'.
      if(sItem2._xscale >= 100) {

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 58: There is no property with the name '_xscale'.
      sItem1._xscale -=1;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 59: There is no property with the name '_yscale'.
      sItem1._yscale -=1;

      **Error** Scene=Scene 1, layer=Layer 1, frame=1:Line 61: There is no property with the name '_xscale'.
      if(sItem1._xscale <=10) {

      Total ActionScript Errors: 20 Reported Errors: 20
      ----------------------------------------------------------------------------------

      Please help me out :-<
      The code :