3 Replies Latest reply on Mar 28, 2015 1:30 PM by ssprengel

    I upgraded to Photshop elements 13 to be able to read files from my new camera....

    asiadra7

      I upgraded to Photoshop elements 13 to be able read raw files from my new camera Olympus em5 mark II .It require ACR 8.8. Currently I have version 8.7.1.311.

      When I wanted update it says that all is up to date.Does it mean that I cant have ACR 8.8 in Elements 13?