4 Replies Latest reply on Feb 8, 2007 8:44 AM by TroyK

    Type in button causing issues???

    Level 7
      I have built a navigation that has a rollout. The buttons are actually
      MCs that I have given actions to. My problem now is that sometimes the
      nav gets stuck on the submenus and I think think it has to do with the
      text in the button/MCs. Just on rollout, they stick, if you put the
      mouse directly over text in the button, especially on letter that cover
      area pretty good, like small e and a. You can see what I am talking
      about here:
      http://www.agilitygraphics.com/clients/capitola/
      The "Production Services" and "Case Studies" buttons corresponding
      rollover sub navigation buttons have this problem.
      I actually placed the hit area in the file(a transparent MC) over the
      text, which makes this even more peculiar to me.

      Anyone have experience with this?

      Thanks a lot in advance!
        • 1. Re: Type in button causing issues???
          TroyK
          I played around with your page for a bit and I don't think it has anything to do with the text, like a and e. Instead, I noticed it has to do with the speed at which I pull away from the button. If I go real slow it sticks every time no matter where my mouse was. If I pull away real quick it doesn't stick once.

          I don't have an answer for you other than a guess. I noticed my "slow/quick" therory only happens on "Production Services" and "Case Studies" and what they have in common is they are the only 2 buttons you have that change text on roll over. So you said you put the transparent MC on top of the text; I would ask when those 2 buttons change text is the transparent MC still the top item?

          I hope this helps somehow.

          Troy
          • 2. Re: Type in button causing issues???
            TroyK Level 1
            Another interesting thing I found, is my "slow/quick" theory only works when you pull away slow or quick from the bottom. If you go over the top it works everytime. So maybe the problem has to do with your blue line under the words.

            Troy
            • 3. Re: Type in button causing issues???
              Level 7
              Troy,
              yeah, you are absolutely right! I just can't figure out what is causing
              that. I took out the line and no difference. I made the hit longer
              downward and same issue... man, this is driving me crazy and I feel like
              I am so close to done...

              Thanks for the help!
              Brian
              • 4. Re: Type in button causing issues???
                TroyK Level 1
                Have you figured it out yet? if not can you put the button in a new flash document all by itself and point me to it so I can download it?