1 Reply Latest reply on Mar 30, 2015 11:46 PM by Peter Spier

    InDesign Add on issues

    hopeb21848219

      I have bought an add on for InDesign and it will not let me down load it to work. It keeps saying I need to have Indesign 8.0 or better, which i do.