0 Replies Latest reply on Apr 26, 2006 12:51 PM by pollardrules

    CF passing XML gets 999 Invalid Input XML error

      Having an XML problem within CF trying to invoke a web service. (Newbie with the XML handling in CF, but gleaned enough from online docs to get code set up.)

      The web service I’m trying to invoke has a test form so that you can paste in your XML, hit submit, and get a packet back just to validate that the XML is formed correctly. Using this test page, my XML works. However, when I implement in CF, I get a 999 error back, “Invalid Input XML.”

      Here’s the XML that worked on the test submit page which I’m using in the code (didn’t include the CF statement on the test form):

      <CFXML variable=”XMLTest”>

      <CFHTTP url="#gUserPostURL#" result="XMLOut" method="POST">
      <CFHTTPPARAM type="XML" value="#tostring(XMLTest)#">

      <CFDUMP var="#XMLOut#">

      <CFSET ReturnXML=XmlParse(XMLOut.FileContent)>

      <CFDUMP var="#ReturnXML#">

      The dump shows the 999 error.

      I’m doing something wrong in the Cold Fusion implementation if the test form works with the same XML, but I’m not sure what I’m doing wrong. I tried using the XML in the code as one long string without the line breaks, but still had the same issue.