4 Replies Latest reply on Jan 31, 2007 9:10 AM by J.C.

    Flex 2 Over https

    J.C.
      I have an Intranet site that also acts as an extranet.

      Intranet address: http://myintranet/
      Extranet address: https://myintranet.mydomain.com/

      My first test Flex application works fine internally, but when I run it while logged in to the Extranet, I get an error stating:

      faultCode:Client.Error.MessageSend faultString:'Send failed' faultDetail:'Channel.Connect.Failed error NetConnection.Call.BadVersion: : url: ' http://myintranet.mydomain.com/flex2gateway/''

      Notice the error has "http" instead of "https" in the message.

      One clue may be that In IIS, I have http://myintranet.mydomain.com set to permanently redirect to it's https counterpart.
      I'm thinking this is basically a setting issue, but I have no clue where to go from here.

      Any ideas would be greatly appreciated.

      JC
        • 1. Re: Flex 2 Over https
          fermartel
          Are you using remote calls to CF in these apps?
          • 2. Re: Flex 2 Over https
            J.C. Level 1
            Yes. Sorry I neglected to mention that.

            Using <mx:RemoteObject destination="ColdFusion"...>
            • 3. Re: Flex 2 Over https
              fermartel Level 1
              To enable flex to use RMI (remote method invocation) over SSL (https), which is what it uses to call the remote cfc's, you need to go to your CF Administrator's Data & Services section, and under Flex Integration enable "RMI over SSL for Data Management".

              To do this, you must first create keystore and keystore password. Go to Help in the CF Administrator, and search for keystore, it will give you instructions on how to do this.

              I have not personally tried this, but it might do the trick.

              Let me know if works please....
              • 4. Re: Flex 2 Over https
                J.C. Level 1
                OK, I've given it a try. I followed the instructions to the letter and I believe I've successfully created the cert. I run the application while logged in via SSL and it performs the same as it did before. I'm still getting the connection error.