4 Replies Latest reply on Apr 1, 2015 12:02 PM by TᴀW

    Which Object Model Version to use?

    szahnje

      I'm new to InDesign scripting, in particular to ExtendScript. When viewing the ExtendScript Object Model API, I was surprised to see that there are dozens of different versions of the API for the same version of CC2014, and that there wasn't an option for older versions of CC, such as 5-5.5 (which many people still use). What's the deal with all of these versions and which one would be the best to program to for maximum backwards compatibility? I'm trying to write a script that will hopefully support InDesign 5- InDesign CC6. Any suggestions?

      2015-04-01_11-26-48.png 2015-04-01_11-26-54.png 2015-04-01_11-27-00.png