1 Reply Latest reply on Jan 23, 2007 3:37 PM by mike_morearty

    Compatibility with previous versions of Player

    Jared Langdon Level 1
      Is it true that Flex apps will only run in Player version 9? Is there a way to compile your SWF such that it is compatible with earlier versions? I.e. is there a subset of functionality that you can use to ensure that your user won't have to upgrade just to use your application? Thanks.
        • 1. Re: Compatibility with previous versions of Player
          mike_morearty Level 1
          It is true that Flex 2 apps will only run in Player version 9. (Flex 1.5 apps will run in earlier versions of the player, but undoubtedly you are asking about Flex 2.)

          But the default HTML wrapper that gets generated for you by Flex Builder uses "express install," which is a feature where if the user has an older version of Flash, they will be asked if they want to upgrade; and if they click Yes, then voila, they get the new player version, with no more clicks required.