5 Replies Latest reply on May 11, 2016 1:15 AM by yze
      • 1. Re: Error executing RDS command. Status Code : 404 , Reason : Not Found
        charlie@carehart.org Adobe Community Professional & MVP

        There can be any number of reasons. First would if the RDS feature is disabled on the server you’re connecting to. Second, that web server (if you are using one) could be configured to block RDS requests (or perhaps even all requests to url’s with CFIDE in them). You could address those, but before you do, please do share more about your use of CFB.

         

        To be clear, are you meaning to intentionally use the feature in CFB where you define a server (and optionally connect a project to that server), so that you can use features to allow you to access server resources (database info, CFC, and more) from within CFB? You would typically only do that in connecting to a development server. Just want to know what your intentions are before leading you to enable something on a server that you don’t really need.

         

        And while we await those answers, and whether the first paragraph may get you going to a solution, is this CF server something you’re connecting to (the RDS url) using the server’s external web server (like IIS or Apache, such as is typical if you have no port in the URL), or via CF’s built-in web server (such as is typical when you have a port like 8500 in the URL)? That may be important in helping to solve your problem.

         

        For instance, if the server (and the URL you’re using) uses IIS, then if you visited the URL for RDS in a browser on the server itself, you may get a much more clear explanation of the problem (since by default, IIS shows more details for requests made ON the sever itself than it does for requests from off the server). The RDS URL (which is generated by the RDS feature in CFBuilder, not something you normally type) is /CFIDE/main/ide.cfm, so append that to the domain or IP address of the server you have configured CFBuilder to use, and see what more detail you may get in your browser.

         

        /charlie

        • 2. Re: Error executing RDS command. Status Code : 404 , Reason : Not Found
          myCharlie Level 1

          Many thanks for the help. I got it working now. I was putting in the wrong host and port number.

          • 3. Re: Error executing RDS command. Status Code : 404 , Reason : Not Found
            NoSoapRadio Level 1

            Charlie:

             

            This thread is kinda stale but I'm hoping that you are still following it as I have the same issue as the original poster. Any time I click on the RDS Data View or RDS File View in CF Builder I get the following alert;

             

            Error executing RDS command. Status Code : 404 , Reason : Not Found

             

            To answer your questions;

            I am trying to set up CF Builder 3 against a local development server (Win XP/Apache 2.2/CF 11/RDS enabled). Note that Apache is set up to use Virtual Hosts.

             

            I also confess to being completely flummoxed by CF Builder's Server Settings.

             

            Thanks.

            • 4. Re: Error executing RDS command. Status Code : 404 , Reason : Not Found
              DCwebGuy Level 1

              I had the same issue today trying to connect CF Builder 3 on my local desktop with a remote instance of ColdFusion 11 over my VPN connection to work.  I am in a Win2008/IIS/CF11 environment.  I had enabled RDS in the CFAdmin but that doesn't do anything if you originally built your server with RDS turned off.  You have to follow these old instructions for manually enabling RDS in your web.xml file:

               

              https://helpx.adobe.com/coldfusion/kb/disabling-enabling-coldfusion-rds-production.html

               

              Once I did this and restarted CF I was finally able to get RDS access to files and databases on my dev machine.  I was able to open, edit, and change live files through RDS very quickly.  Previously I had been trying to open and edit files through mapped drives via the File Viewer, but this didn't work at all, it was extremely slow to the point of not working.  With RDS everything was super fast.

               

              I know you are supposed to use source control and work on local copies.  We are getting there.  This particular issue of live file access is in response to IT shutting down use of Dreamweaver.  In any case, I hope this helps someone who is trying to set up a remote RDS connection or having trouble opening files in CFB via mapped drives.

              • 5. Re: Error executing RDS command. Status Code : 404 , Reason : Not Found
                yze

                I was also frustrated to find so little help about this.

                The following thread gave me a hint to solve my problem: CFB Setup Issues when using Virtual Hosts

                 

                When trying to create a RDS connection in CFB I was getting the 404 error, as described in the original post.

                 

                I had RDS turned on in CF Admin, I had double checked that the RDS stuff wasn't commented in the web.xml file in WEB-INF, and checked the password, and everything was ok.

                I have ColdFusion Builder 2016 setup on my local PC with Windows 10, and I am also locally running Coldfusion 11 and Apache via XAMPP. It turned out that the virtual host definitions in my httpd-vhosts.conf file was the source of the problem.

                 

                For example, I had the following:

                NameVirtualHost 127.0.0.1

                <VirtualHost 127.0.0.1>

                  DocumentRoot D:\wwwroot\local

                  ServerName www.local.local

                </VirtualHost>

                 

                The thread I linked to above, linked to another thread at Stackoverflow http://stackoverflow.com/questions/10456379/setting-up-virtual-hosts-in-apache-2-2 about setting up virtual hosts, that suggested to use *.80 as the NameVirtualHost.

                I replaced every instance of 127.0.0.1 in my httpd-vhosts.conf file with *.80, saved it and restarted Apache. Now, believe it or not, CFB could connect via RDS!

                 

                This is my settings in CFB. (Note that it didn't work if I changed Host Name to 127.0.0.1 and keeping my old vhost file)

                 

                cfb.png