5 Replies Latest reply on Apr 11, 2015 1:20 PM by marias50244007

    Adobe reader keeps saying it needs to be updated and is blocking plug ins, but won't update. what do i do?

    kristak93882466

      Adobe reader keeps saying it needs to be updated and is blocking plug ins, but won't update. what do i do?