10 Replies Latest reply on Apr 9, 2015 10:22 AM by georgeb604087

    Y rotation not working properly

    georgeb604087

      Hello, I'm new to after effects, but my issue is strange. I have created 3d text and rotated it say 3 full rotations and have also used elements 3d to created text and logos and rotated them, but now for whatever reason when I try to do it all it will do is sort of stretch the text and logo around in a circle instead of spin the text or logo and I can not figure out why, please help. It is not an anchor point issue either.

        • 1. Re: Y rotation not working properly
          Mylenium Most Valuable Participant

          Nobody can tell you anything without seeing your actual settings for the comp, the properties and so on. You haven't even told us what version of AE, so what are we supposed to tell you? You need to provide much more useful info.

           

          Mylenium

          • 2. Re: Y rotation not working properly
            Szalam Adobe Community Professional & MVP

            Screenshots would likely help too.

            • 3. Re: Y rotation not working properly
              Rick Gerard Adobe Community Professional & MVP

              Without a screenshot with all of the properties of all the layers in your comp that are giving you problems revealed we cannot know what is going on. I suspect that you may be trying to incorrectly rotate your Element layer.

               

              Select the layers giving you problems, press the U key twice, capture a screenshot and then just drag the full sized screenshot into the Reply window of this forum to upload it, then describe anything that isn't clear in detail.

              • 4. Re: Y rotation not working properly
                georgeb604087 Level 1

                Untitled.jpg

                 

                I am running after effects CC and Elements 3D. I have rotated text and logos before with no issues, and now it just stretches it and rotates it in like a circle instead of stationary rotation, the x and y rotation are both doing this. As you can see there are not multiple layers and nothing complicated, just simply trying to spin text or a logo 360 degrees. Please understand that I am new to after effects, but I must be missing something, thanks in advance for your help.

                • 5. Re: Y rotation not working properly
                  Rick Gerard Adobe Community Professional & MVP

                  You have created a camera with an incredibly short focal length and a very wide angle of view and then placed the camera very close to your 3D elements. Perspective is controlled by camera position not angle of view so you need a much longer lens and to move the camera back. Try resetting the camera focal length to 50MM or about 8890 pixels and reposition your camera. The longer your lens and the farther away the camera is from the subject the more "normal" the shot will look.

                   

                  I wouldn't be rotating the camera this way anyway. I'd either use an Orbit Null to rotate the camera or animate camera position and point of interest.

                  Screen Shot 2015-04-09 at 9.18.59 AM.png

                  • 6. Re: Y rotation not working properly
                    Szalam Adobe Community Professional & MVP

                    You need to check on your camera settings. That looks like an AWFULLY wide-angle lens you've got there.

                    • 7. Re: Y rotation not working properly
                      georgeb604087 Level 1


                      I have changed the camera to 50mm and it is still doing the same thing. Usually I just put say 3 in for the y rotation and it will rotate 3 times over my set key frame period. From the top view I can see the camera is fixed and rotating in a fixed position and not rotating around the text so that is the issue. Endless I am missing something, shouldn't I just be able to rotate the text, very confused over a simple issue, lol.

                      • 8. Re: Y rotation not working properly
                        Szalam Adobe Community Professional & MVP

                        It looks like your camera is really close. Move it back - your text might get too small, but zoom your camera in/change the focal length and it should be better.

                        • 9. Re: Y rotation not working properly
                          Rick Gerard Adobe Community Professional & MVP

                          If you want to rotate (orbit) the camera around your 3-D layers then use the tool I described to create an Orbit Null and animate the Y rotation of the null.

                           

                          If you want to rotate your layers, because you are using Element 3D the project is going to get a lot more complicated.

                           

                          If you type "animate camera" in the search help field at the top right corner of the After Effects app it will take you to a bunch of tutorials and instructions on how to animate the camera inside AE. It will make a lot more sense to you after you've done a little research.

                          • 10. Re: Y rotation not working properly
                            georgeb604087 Level 1

                            OK guys, I have it figured out, sorry for wasting your time, All I have to do is select my black solid layer that has the elements 3d effect on it, go to the effects panel, select world transform and then Y rotation world and key frame it over time. It now spins in fantastic high detailed 3D, sorry for the confusion and thank you for the help guys.