1 Reply Latest reply on Jan 15, 2007 9:38 AM by JavierShLf

    RemoteObject: No returning collections with Tomcat

    JavierShLf
      Hello,
      I have installed and configured FDS in Tomcat. Samples are working OK. I'm trying to develop a very simple example (in the same samples application) calling a java class as a destination of a remote object. The java class is returning a java.util.List. I've included a trace in the java class and it's being called and working OK, but I can't see the results in the DataGrid.

      Here is the code:

      <mx:RemoteObject id="srv" destination="depsSRV" showBusyCursor="true">
      <mx:method name="getDeps"/>
      </mx:RemoteObject>
      <mx:ArrayCollection id="ac" source="{srv.getDeps.lastResult}"/>

      <mx:DataGrid id="dgDep" x="55" y="88" height="149" dataProvider="{ac}" width="230">
      <mx:columns>
      <mx:DataGridColumn headerText="cod" dataField="cod" width="50"/>
      <mx:DataGridColumn headerText="name" dataField="name" width="180"/>
      </mx:columns>
      </mx:DataGrid>
      <mx:Button x="136.5" y="41" label="Search" click="srv.getDeps.send()"/>

      After invoking the remote object, the java class executes (as I can see in the trace) but no result are atored in the ArrayCollection.

      The definition of the destination is as simple as:
      <destination id="depsSRV">
      <properties>
      <source>services.DepLoc</source>
      </properties>
      </destination>

      Can someone help me?
      Thank yo very much