3 Replies Latest reply on Apr 10, 2015 3:43 PM by A.T. Romano

    [Mac] system requirement version 11

    mbjacobs

      Bought Premiere Elements 11 off ebay - new, unopened sealed box.  Box says mac OS 10.6-10.8 is required.  I'm running 10.6.8 but when I try to install the software it insists that 10.8 is required.  I really don't want to upgrade my OS because the newer systems don't support some of the older software I use.

       

      [Title edited... Mod]

        • 1. Re: [Mac] system requirement version 11
          A.T. Romano Level 7

          mbjacobs

           

          The Adobe System Requirements for its versions can be found in the following Adobe document

          https://helpx.adobe.com/premiere-elements/kb/system-requirements-premiere-elements.html

           

          As you will see the System Requirements for 11 Mac include

           

          Mac OS

           

             

          • 64-bit Multicore Intel® processor.
          • Mac OS X v10.6 through v10.8.
          • 2-GB RAM

           

          The Premiere Elements 11 Mac installation disc's ReadMe file also says the same thing.

           

          Is it possible that your Mac computer does not have a 64 bit Multicore Intel processor? That might be the answer.

           

          Just in case note....are you working with Premiere Elements 11 Editor from the Mac App Store or the Premiere Elements 11 Mac from Adobe?

           

          We will be watching for your progress.

           

          ATR

          • 2. Re: [Mac] system requirement version 11
            mbjacobs Level 1

            After lengthy discussion with Adobe tech service I downloaded (4 hours) another copy of Premiere Elements.  Installed using the serial from the package I purchased.  It gave me the same error message then went ahead and installed.

             

            My mac does have a four core, 64 bit processor. 4-GB RAM.

            • 3. Re: [Mac] system requirement version 11
              A.T. Romano Level 7

              mbjacobs

               

              Thanks for the follow up with the great news that Premiere Elements 11 did finally install on your Mac Computer.

               

              What triggered the install after the error message? Was it a series of hitting a continue button or something else?

               

              Classically Adobe Technical Service does not support other than the current version (would be 13) and even then the support is limited and often ends with "Ask the Community". But, glad it all worked out for you.

               

              Best wishes as you move forward with your Premiere Elements projects.

               

              ATR