5 Replies Latest reply on Apr 22, 2015 6:22 AM by redwoodtwig

    Why is LR 5.7.1 is locking up my Win 7, 64 bit computer completely?

    redwoodtwig Level 1

      I can no longer use LR because every time I try to start, it goes non-responsive.  I was able to start the task manager one time and it showed that CPU is zero, and memory is 10 GB (out of 24) and LR is non responsive.  But within a few minutes the task manager and any other programs I might have running also become non-responsive, including the start button.  I  have to use the physical reset button.

       

      I thought perhaps it was related to the fact that I used to have plain LR and had subscribed to CC, the PS/LR combo.  So I uninstalled what the computer said I had, namely LR 4.4 and 5.7.1, and then used CC panel to download and install LR.

       

      Same thing happens:

      The initial catalog selection dialog comes up and when I select the main catalog I normally work in, the whole computer locks up.  The LR splash shows.

       

      And, since I have to do a cold reboot, the lock file remains behind and then I get that other message about another program using the catalog.  Delete the lock file, but that doesn't change anything, still same behavior.

       

      When I select another catalog, same thing happens.  When I tried to create a new catalog, after starting to create it, a message box came up saying something about the smugmug plug in  (box was smaller than message), and the system locked up and I had to do a physical reboot.

       

      It may also be significant that shortly after signing up for CC, I started getting the Windows "switch to" messages, telling me the LR thought another copy of itself was running.  Task manager did not show that.  And in any case, a couple of mouse clicks and things seemed to have been working fine. 

       

      Also at one point I did get a message that the database for the catalog was corrupt and I was able to run the correction and it told me it was fixed but then it went into never-never land.  (I did notice it trimmed 4MB off the catalog size. 

       

      I hesitate to try opening my latest backup, especially after discovering that I got the same error on a much smaller catalog I hadn't used in several months.

       

       

      What else can a I do that might untangle whatever is causing this?

       

      Thanks,

        • 1. Re: Why is LR 5.7.1 is locking up my Win 7, 64 bit computer completely?
          dj_paige Level 9

          Locking up the entire computer very likely is either

           

          • A hardware malfunction
          • Bad video driver

           

          One likely cause is that you have a malfunctioning fan in the computer, causing the computer to overheat. But there could be plenty of other hardware issues.

          • 2. Re: Why is LR 5.7.1 is locking up my Win 7, 64 bit computer completely?
            redwoodtwig Level 1

            As it happens, the fan wasn't working that good and I'd planned to blow the dust out anyway.  That fixed the noisy fan.

            Also went out and found the latest driver for the GeForce card and installed it.

             

            Still same thing with LR.  Goes to catalog select dialog, accepts my choice, shows the splash image, then after a bit shows a black box behind the splash image.  When I start the task manager before hand, I can see LR takes up .03 CPU and about 150MB memory and stops there.  And for a few minutes, I can work another app, but after about 10 min, nothing responds at all.

             

            Before trying LR again, I went through the other apps I use, such as Photoshop, Evernote, Chrome, firefox.  Everything else works fine.

            • 3. Re: Why is LR 5.7.1 is locking up my Win 7, 64 bit computer completely?
              dj_paige Level 9

              There are other fans, and other hardware that could be failing.

              • 4. Re: Why is LR 5.7.1 is locking up my Win 7, 64 bit computer completely?
                redwoodtwig Level 1

                I checked all the fans.  Hardware is not the problem, since all my other programs work.  Including monsters like photoshop and Sony Vegas

                 

                I did go in and rename the LR preferences file and it went from just showing the splash image to showing the LR window with top and bottom bars, but no side bars and just grey in the middle.  I let it go and after about an hour, the computer rebooted itself.

                 

                I figure what I need is to completely delete the LR install somehow.  I had LR under the regular purchase license, but I've been on the photographer creative cloud for several months.  Is there some special set of steps I can take to insure there is no trace of the old regular purchase version if that is what might be causing the problem?

                • 5. Re: Why is LR 5.7.1 is locking up my Win 7, 64 bit computer completely?
                  redwoodtwig Level 1

                  It turned out to be a failing disk drive, the drive that had the catalog on it.

                  I had to set up the disk check tool, which had to be run on boot up because the disk had the user profiles on it. (explorer, right click on drive in left panel, select tools and the "check disk for errors" tool.)

                  It ran for several hours, but at 11% through stage 4 of 5, verifying file data, it stopped and went no further. So apparently at least one of the files couldn't be verified.  Without going into detail, I was able to copy the files I needed to another drive (robocopy), swap drive letters around using diskpart and get back into operation.

                   

                  So, apparently LR needs some additional error handling related to file handles.  Somewhere in the initial load of a catalog a file read failed and the LR code doesn't have a handler for that kind of error.  What should happen, in my opinion, is that the LR error handling should have displayed a message that indicated an unexpected hardware fault, most likely disk related and recommended I run CHKDSK on the drive where the catalog is located.