0 Replies Latest reply on Apr 16, 2015 1:14 PM by eleanors75044956

    my macbook pro OSX 10.6.8 does not support lightroom 5 - is there any way I can install an earlier verion of Lightroom?

    eleanors75044956

      my macbook pro OSX 10.6.8 does not support lightroom 5 - is there any way I can install an earlier verion of Lightroom?

      (am hopeless at this stuff, probably a very basic question,apologies!)