5 Replies Latest reply on May 18, 2015 9:16 AM by ereddings

    Strange Error with RHCL command line compile in RH10 and RH11

    ereddings

      Hello again, RoboHelp Gurus!

       

      I'm experiencing a strange error using the rchl command line compile process in both RoboHelp 10 and RoboHelp 11.

       

      Here's the cmd I'm using:

       

      cd "C:\Program Files (x86)\Adobe\Adobe RoboHelp 10\RoboHTML"

      rhcl "C:\folder\project.xpj" -l "SSL_Name" -o "c:\outputfolder" -g "C:\log\folder\logfile.txt"

       

      When I generate the logfile from the cmd, I see an error "LILo: BIBCientInit failed to initialize" twice in the cmd prompt window while the compile is processing.  The cmd prompt window looks like this:


      C:\Program Files (x86)\Adobe\Adobe RoboHelp 10\RoboHTML> rhcl "C:\projectfolder\project.xpj" -l "SSL_Name" -o "c:\outputfolder" -g "C:\logfolder\logfile.txt" [PRESS ENTER]

      LILo: BIBCientInit failed to initialize

      LILo: BIBCientInit failed to initialize

      C:\Program Files (x86)\Adobe\Adobe RoboHelp 10\RoboHTML>


      The logfile.txt created has no mention of "LILo: BIBCientInit failed to initialize" within it.  The compile builds without problem, as far as I can tell.

       


      The same thing occurs when I do not create the log file during the cmd, and it errors right acter "Clearing output folder".  But, it appears to me that the output folder does not actually get cleared.


      This allow viewing of the compile process line by line in the cmd prompt window.  When the compiler shows "Clearing output folder..." , the "LILo: BIBCientInit failed to initialize" message error displays twice, then the process continues.

       

      Here's that command:

       

      cd "C:\Program Files (x86)\Adobe\Adobe RoboHelp 10\RoboHTML"

      rhcl "C:\folder\project.xpj" -l "SSL_Name" -o "c:\outputfolder"

       

      The cmd prompt window looks like this:


      C:\Program Files (x86)\Adobe\Adobe RoboHelp 10\RoboHTML> rhcl "C:\projectfolder\project.xpj" -l "SSL_Name" -o "c:\outputfolder" [PRESS ENTER]

       

      Adobe (R) RoboHelp Project Command Line Compiler version 10.0.0.287

      Copyright (C) 2006-2007, Adobe Systems Incorporated and its licensors. All rights reserved.

       

      Project: C:\folder\project.xpj

      Layout: SSL_Name.

      Output: c:\outputfolder.

       

      Scanning project for compilation....

      Scanning finished.

      Warning: No baggage file description.

      Starting compilation...

      HTMLHELP preprocessor 10.0.0.287

       

      Compiling C:\folder\!chm_tmp_folder_0\project.xpj ...

       

      Preparing to create HTMLHELP...

      Clearing output folder...

      LILo: BIBCientInit failed to initialize

      LILo: BIBCientInit failed to initialize

      Preparing files for HTML Help...

      Copying files...

      ...

       

      It doesn't matter if it is an HTMLHelp or a WebHelp output.  Any thoughts on what this error is and/or what's causing it?

       

      I've been away from RoboHelp for about 9 months, but I've come back to the same projects and the same version of RoboHelp 10 and the same compile processes.  The difference is that I have a new laptop.

       

      Many thanks in advance for your time!

      ee