1 Reply Latest reply on Apr 24, 2015 7:01 AM by SimonATS

    Echosign button not updating in production Salesforce org

    kevin sirface Level 1

      Greeting all,

      I am having trouble with an Echosing button: It works perfectly in Sandbox and the button code there looks like this:

      https://echosign-dev1.cs10.visual.force.com/apex/EchoSignAgreementAdvanced?CF00NJ0000001hd ut={!Account.Name}&CF00NJ0000001hdut_lkid={!Account.Id}&scontrolCaching=1&retURL=%2F{!Account .Id}&sfdc.override=1

       

      I installed Echosign into Production and updated the IDs for the org and the button code looks like this:

      https://echosign-dev1.cs10.visual.force.com/apex/EchoSignAgreementAdvanced?CF00NU00000058A 3B={!Account.Name}&CF00NU00000058A3B_lkid={!Account.Id}&scontrolCaching=1&retURL=%2F{!Account .Id}&sfdc.override=1

       

      The sandbox button works perfectly. The Production button, when clicked, takes me to the test.sandbox login page. So when I login (using my sandbox creds) it takes me to the correct page BUT in the Sandbox!

       

      So can anyone find a problem with the button code OR have any familiararity with Echosign settings that may need to be updated?

       

      Thanks in advance

      Kevin

        • 1. Re: Echosign button not updating in production Salesforce org
          SimonATS Adobe Employee

          Wouldn't this part of your url:

          https://echosign-dev1.cs10.visual.force.com/apex

          be different too for your production environment.

           

          Also not how we document to use custom buttons, have you have a look at the customization guide on how to add custom buttons to send esign agreements? (page 25 onwards)

           

          For example page 35 of the v15 customization guide:

          Example: You can define a ‘Send to EchoSign’ button so that when clicked, it will bring the user to a specified URL or back to the record instead of going to the Agreement page. To define this button, use this string as an example:

          /apex/echosign_dev1__AgreementTemplateProcess?masterid={!Account.Id}&templateId=a01U00000 04pImMwhere&retURL=/{!Account.Id}

           

          where templateId should be set to the specific ID of the agreement template that is to be used.

           

           

          [moving to sfdc subforum]