1 Reply Latest reply on May 9, 2015 1:51 PM by ian lewis

    extension manager says I need a newer version of photoshop when I already have the most current version cc2014

    lances62209392

      extension manager says I need a newer version of photoshop when I already have the most current version cc2014. Any thoughts on this?