1 Reply Latest reply on Feb 7, 2007 1:52 PM by Vogtwa

    FDS Could not find the Coldfusion Component

      I am currently running CFMX 7.0.2 (w/ a multiserver configuration using IIS) and FDS 2.0 w/ JRun4, using Flex Builder 2.0.1 Standalone as my Flex IDE.

      I am able to do remoting without a problem, and I am also able to run the FDS CRM sample, which uses Java. But when I try to use FDS + CF, it tells me "Could not find the Coldfusion Component samples.contact.ContactAssembler".

      I have been following the Contact Manager example, originally posted by Tom Jordahl and later corrected by Steven Erat.

      I am pretty sure that I have done everything correclty:

      - I have all the mxml files placed in the E:\jrun4\servers\default\samples\dataservice drectory, and have modified the DataService destination to point to "cfcontact", not "cfcontact-default".
      - I have added the destination element from E:\resources\config\data-management-config.xml to E:\fds2\jrun4\servers\default\samples\WEB-INF\flex\data-management-config.xml
      - I have added
      <adapter-definition id="coldfusion-dao" class="coldfusion.flex.CFDataServicesAdapter"/>
      to E:\fds2\jrun4\servers\default\samples\WEB-INF\services-config.xml
      - I have unzipped the CF files into my CF root (<CFroot>/samples/contact/) and the access file into <CFroot>/samples/contact/db/. I also tested the CFC's to makes sure they worked properly on their own
      - I have made a datasource called FlexDataServices pointing to the access file, and made sure it works correctly
      - I have started the FDS server with no errors

      But when I run the app from http://localhost:8700/samples/dataservice/contact/contactmgr.mxml, it gives me that error: "Could not find the Coldfusion Component samples.contact.ContactAssembler".

      So i know FDS works with Java, its CF that is giving me the problem. Could it have something to do with the fact that I am using IIS for CF and JRun4 for FDS (even though I dont think so since the calls to the cfc's are not http, or so think)

      Any help would be greatly appreciated...i have been trying to get this to work for a couple of days and would love to move on.

      Thank you.