2 Replies Latest reply on Apr 24, 2015 11:35 AM by michaels61983273

    How can I use After Effects CS5 under Mac OS X Mavericks?

    michaels61983273

      After I upgraded my late 2013 Macbook Pro to Mavericks, and reinstalled my CS5 Master Collection, I have found that After Effects will not start.

       

      The first time I tried it, it appeared to start as normal, but after it went through the start up sequence, put up a dialogue box that stated it was unable to rename a file deep within the Users folder from Workspaces(with a long random number appended).xml to Workspaces.xml.

       

      So, after a year of on and off again searching for answers to the question "WTF?" I finally opened up my Terminal and created a file named Workspaces.xml in the directory that the app was pointing to since that first day, way back when.

      So now, when I start up AE, I get a different error message.

       

      "

      After Effects warning: Error parsing properties list from file "/Users/michaelsprague/Library/Preferences/Adobe/After Effects/10.0/Workspaces.xml".

      "

       

      This is then followed, upon clicking OK, by

       

      "

      After Effects warning: Workspaces Manager not initialized

      "

      and then, finally

       

      "

      After Effects can’t continue: unexpected failure during application startup

      "

       

      Each dialogue has one option - an OK button.

       

      So, I am wondering how I might go about giving the program the parameters it needs to be able to start up.

       

      Presumably I can type them in to the file I created, or, could if I knew what to type.

       

      What is AE CS5 looking for?

        • 1. Re: How can I use After Effects CS5 under Mac OS X Mavericks?
          Todd_Kopriva Level 8

          See this:

          fixing permissions problem that impedes start of Adobe applications

           

          Note that After Effects CS5 is not supported on Mac OSX v10.9 (Mavericks).

          • 2. Re: How can I use After Effects CS5 under Mac OS X Mavericks?
            michaels61983273 Level 1

            I post this here in the hopes that it may help someone who ran into the same roadblock I ran into. I do not know if this application will work for me in the long run, but I have finally succeeded in getting it to start. I expect that I will hit other stumbling blocks in the future, which I will deal with then.

             

            So, yes - After Effects CS5 is not supported on Mavericks, but eventually you can make it start.

             

            What I did was the following.  I do not know how much of this was necessary, but it is what I did.

             

            1.  As noted above, AECS5 had a problem at startup with renaming a file to Workspaces.xml.

             

            I think this may be a file that is auto generated when AE starts up, given that each time I tried to startup the app, it was failing to rename a slightly differently named file to Workspaces.xml. (each one had a different number appended between the filename and the dot separating the filename extension)

             

            2.  I thought "OK, I know how to go in and give it a file named Workspaces.xml,, and perhaps that will short circuit this problem.

             

            I was half right.  After I found my way, in Terminal, to the area I wanted to add that file to, switched to superuser mode so I could do some real damage, and accomplished the task the error message changed. Instead of not being able to rename a file, it was now having an issue with parsing from that file.

             

            Easy to understand, since it was a blank-ish file, with only a *. comment /* line included to say what it was there for.

             

            3. So, I came here and asked the question. Got a response re: quicktime not playing nice with AE which thoroughly confused me, since there was no indication of a QT involvement in this.  Still, a nice person took the time to respond to my question, and included a pair of links for my further edification. It would be rude to just ignore that.  Unfortunately, as much as I appreciate the time and effort required, it did not seem, at first, as though there were any there, there.

             

            However, I did continue reading, and then saw another link along side my original post where there had not been anything listed under similar threads before.

             

            I followed the first one, and it seemed to suggest that permissions were involved, which seemed logical, given the original "failed to rename" error I had been receiving.  The article recommended giving my preferences files read and write permissions, which I was hesitant to do, particularly when there was no real info regarding who or whay exactly to give those permissions to.

             

            Aside: typically, permissions are assigned on an account by account basis, or to group.  U G O (User - me Group - those added as members of a work group by me, the U ser and Other - everyone else)

             

            So, giving permission to read and write to all of the above seemed a bad idea, but since I was skeptical of the idea that this might magically clear up the problem I had with just starting up AECS5 at all, and because I affect a devil may care attitude in general, I decided "Fine, I will just give the world these permissions... at least I am not making these universally X (executable) (as if that makes any diff) ,

             

            So, again I switched to superuser mode, and gave all groups read and write permissions (chmod ugo+rw Permissions/ )
            Then I clicked on the AE icon in the dock, and - Ta Da - it did not start.

             

            So, I altered the chmod command slightly, to chmod ugo+rw -R Permissions/   - to make it recursive, and truly give the world permission to read and write to all of my Preferences, once they all hack in to my system.

            So, bottom line is, I do not yet know how messed up the rest of my system is, due to these permission changes on my preferences files for everything installed here, but After Effects CS5 is now started up on my system.

             

            Thank you, Todd, for the response and the noodge I needed to get this resolved.