3 Replies Latest reply on Apr 26, 2015 5:15 PM by A.T. Romano

    Canon elura 80 not recognized by Premier elements 13 and won't download videos. Please help.

    fredv68236479

      Just bought a new very powerful gaming powerspec computer, very souped up and expensive.  Bought a vantec 2+1 combo firewire 800/400 card to allow download of my canon elura 80 DV camcorder videos.   Hooked the camcorder up to the computer, turned it to VCR mode (Play) and it "sees" the canon elura 80 and recognizes it as such in the devices menu on the computer.  However when I open elements 13 and use the add media to download the videos, it does not "see" the camera.  Have followed all directions.  Have gone into the control panel for hardware to see that the elura would use premiere  for its default program.  Have tried every one of the options on the add media drop down.   Have verified the cable is good. 

       

      Have an old HP computer that came with a 4 pin firewire on the compurter and it is running Premiere elements 8 - it works fine - sees the camcorder, am able to download the video to the computer, etc.  Checked this after it would not run on the new computer.  Then went back to the new computer and still nothing. 

       

      Also was able to run this camcorder on a very old XP machine using Pinnacle software  and the same cable I am using on the new computer (how I know the cable works).  

       

      Any help would be appreciated - called Microcenter the powerspec computer seller - they said since the computer recognizes the canon elura 80, it must be the software and they recommended calling adobe.  - Very frustrating.