20 Replies Latest reply on Aug 25, 2016 12:33 PM by water bowl

    Help not working in Lightroom CC.

    ric80231

      When clicking on help in Lightroom CC the web address that the browser is directed to 'http://community.stage.corp.adobe.com/chcservices/services/redirect?u=http://help.stage.ad obe.com&p=Lightroom_6.0&l=en_U…' is incorrect. My browser reports that the server community.stage.corp.adobe.com is not found.

        • 1. Re: Help not working in Lightroom CC.
          Dave Merchant MVP & Adobe Community Professional

          It's a bug - that URL is the internal Adobe testing server which is not accessible to the public.Seems nobody bothered to check the code...

           

          The correct URL is https://helpx.adobe.com/lightroom.html

          • 2. Re: Help not working in Lightroom CC.
            ric80231 Level 1

            If the solution is so simple why hasn't it been fixed? CC is supposed to mean updates are available quickly.

             

            FInally, if Lightroom CC can be released with such a stupid error. My confidence in your quality control has plummeted.

            • 3. Re: Help not working in Lightroom CC.
              wolfgangh37577831 Level 1

              Ich hoffe, das Problem wird bis zum Ende meiner Testperiode - noch 19 Tage - beseitigt. Dann müsste ich nämlich meine Kaufentscheidung treffe.

              Bei der englischen Version scheint es ja nach dem Update zu funktionieren.

               

              Es ist doch traurig, dass solch ein grober Fehler durch die Qualitätskontrolle kommen konnte

              • 4. Re: Help not working in Lightroom CC.
                Grimbaldus

                Three weeks after the first post and it's still not been fixed ... unbelievable!  If they don't want to put out an updated version - and I thought CC was supposed to facilitate quick and easy updates - then put a redirect into the firewall.  It's not rocket science.

                • 5. Re: Help not working in Lightroom CC.
                  mcucinat Level 3

                  Actually, it has been corrected two weeks ago...

                  Have you checked the Creative Cloud updates?

                   

                  Please open Help -> System Info and look at the first lines of the report. It should read:

                  Lightroom version: CC 2015.0.1 [ 1018573 ]

                  License: Creative Cloud

                  Operating system: Windows 7 Enterprise Edition

                  Version: 6.1 [7601]

                  • 6. Re: Help not working in Lightroom CC.
                    wolfgangh37577831 Level 1

                    @ mcucinat

                     

                    this are the first lines of my system Info:

                     

                    Version von Lightroom: CC 2015.0.1 [ 1018573 ]

                    Lizenz: Testversion

                    Betriebssystem: Windows 7 Home Premium Edition

                    Version: 6.1 [7601]

                     

                    and the help is NOT!!! working. What you mean about this??  Or is the help in trial period normally disabled???

                    • 7. Re: Help not working in Lightroom CC.
                      mcucinat Level 3

                      No, it should work with 2015.0.1, Licensed or Trial.

                       

                      In fact, the patch 2015.0.1/6.0.1 was expressly released to correct 2 issues: Lightroom sometimes hanging when not connected to internet and the help menu pointing to the wrong URL.

                      I personally experienced the second issue and it was solved as soon as I installed the update.

                       

                      Please try to completely uninstall and reinstall Lightroom and/or reset the preferences file.

                      • 8. Re: Help not working in Lightroom CC.
                        wolfgangh37577831 Level 1

                        Please read all my posts. I have already several times LR reinstalled just the preferences file deleted just once. Nothing helps. My Creative Cloud Version is 2.0.1.88.
                        The problem also does not seem to lie in the Help URL, but the fact that the browser at F1 / Help will not open. This all works fine in my LR 5.x version. I also have the standard browser (IE or Firefox) changed several times, without success. I disabled my firewall and my security suite, no success.
                        Other, browser-based functions such as account management or LR online work well. And my other Adobe software work also fine.
                        I am currently close to despair, and expect a professional support to solve the problem. The decision to buy LR and future Adobe products I have to depend on this problem solving.

                        • 9. Re: Help not working in Lightroom CC.
                          mcucinat Level 3

                          Wolfgang, first of all, to see all your posts you should have sent me the link to the other thread (Lightroom 6 help not found), I had to search your activity to understand what you were talking about...

                           

                          Second, I was answering to Ric & Grimbaldus, who have the following error: Help button links to community.stage.adobe.com...; your error is completely different.

                          In your case Lightroom is not able to interface with Windows to launch the external http command, so it is more an OS problem than a Lightroom problem. you may have something wrong in the Windows registry.

                          Have you tried to read this topic? Error launching Help | Adobe applications | Windows

                           

                          Third, if your decision is solely based on a help button not launching the browser (workaround: click on this link Lightroom Help) and you ignore all the other features of the software, well...

                          • 10. Re: Help not working in Lightroom CC.
                            wolfgangh37577831 Level 1

                            mcucinat,

                            thanks for the additional information. Excuse me, I forgot the link to my other posts.
                            I have the instructions executed from the Post: "Error launching Help | Adobe applications | Windows". There was no improvement. I also do not understand why the function in my LR 5.7 Installation works and LR 6 not. Both are located on the same computer, and it will probably (i think so) also used the same routines for both programs.
                            What else can I investigate to find the problem ?? Can it be that the command for calling the help of my old LR 5.7 installation is linked again and the command from the installation LR6 goes nowhere.

                            • 11. Re: Help not working in Lightroom CC.
                              mcucinat Level 3

                              Can you try to execute this line in the command shell:

                               

                              reg query hkcr\http\shell /s

                               

                              and give me the results you get?

                               

                              Then I ask you to do another experiment: execute Lightroom 6 as an Admin (click right on its icon and select "run as administrator"), then press F1 and tell me if this time the internet browser opens.

                              • 12. Re: Help not working in Lightroom CC.
                                wolfgangh37577831 Level 1

                                THX for your quick response

                                 

                                this are the results of the command shell with admin rights:

                                 

                                Microsoft Windows [Version 6.1.7601]

                                Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.

                                 

                                C:\Windows\system32>reg query hkcr\http\shell /s

                                 

                                HKEY_CLASSES_ROOT\http\shell

                                    (Standard)    REG_SZ    open

                                 

                                HKEY_CLASSES_ROOT\http\shell\open

                                    CommandId    REG_SZ    IE.Protocol

                                    DontReturnProcessHandle    REG_SZ

                                 

                                HKEY_CLASSES_ROOT\http\shell\open\command

                                    (Standard)    REG_SZ    "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -osint -url "%1"

                                    DelegateExecute    REG_SZ    {17FE9752-0B5A-4665-84CD-569794602F5C}

                                 

                                HKEY_CLASSES_ROOT\http\shell\open\ddeexec

                                    (Standard)    REG_SZ

                                 

                                 

                                C:\Windows\system32>

                                 

                                Help is not working like before, as admin also.

                                • 13. Re: Help not working in Lightroom CC.
                                  Jossi2a

                                  HELP, NOR TUTORIALS ARE WORKING IN LIGHTROOM 6, WITH WINDOWS 10.

                                  if THERE IS A PATCH OR WHATEVER, I WOULD LIKE TO HAVE IT ASAP. 

                                  • 14. Re: Help not working in Lightroom CC.
                                    chrisw15848370

                                    Just installed, uninstalled and reinstalled stand-alone LR6.0 running on Yosemite 10.10.5 and I'm having the same problems with F1/Help that were reported going back to April 2015.  Does Adobe have a fix for this yet? If so, what is it, and why was it not included in the download I purchased on October 26, 2015?  If not, why not?

                                    • 15. Re: Help not working in Lightroom CC.
                                      NYNC Level 1

                                      Have had same problem with being directed to wrong help URL since original version of LR CC and LR 6.0. (I have both LR CC and perpetual version). Uninstalled and reinstalled. Tried different browsers as default. Updated with each and every update including this week's update that reverted to original Import dialog. Talked on phone with Adobe rep who verified that my updated versions should have included the fix (back at 6.01.) We're at 6.3 now, but LR still misdirects to wrong URL. Any ideas? Any hope of a fix before LR 7?

                                      • 16. Re: Help not working in Lightroom CC.
                                        jbabacus

                                        I agree that you (Dave Merchant) have given the correct URL, but that does not fix the F1 problem. I think I found a solution. It seems to be working: rename Lightroom_6.0.helpcfg to xLightroom_ etc.

                                        I used an x so I could find the file again in case I did not really fix the problem. The 6.0 help file worked for LR6, but not for LR 2015CC. Apparently CC will continue to use the 6.0 helpcfg if it is present.

                                        I hope this works for others having the same problem. I assume the 6.0.1 patch was supposed to fix the problem, but should have deleted the old file.

                                        • 17. Re: Help not working in Lightroom CC.
                                          liss@henrikssons.net Level 1

                                          Hello

                                           

                                          i renamed the help file to xLightroom_6.0.helpcfg but than i dint work at all and ask me to reinstall lightroom, please advice what to do

                                          • 18. Re: Help not working in Lightroom CC.
                                            liss@henrikssons.net Level 1

                                            Hello

                                            I have now also clean chashe in the webbrowser but no change, i have also change the language in LR from swedish to english but still same problem F1 help link still not work http://community.stage.corp.adobe.com/chcservices/services/redirect?u=http://help.stage.ad obe.com&p=Lightroom_6.0&l=en_U…  

                                            and same story page cant be viewed.

                                             

                                            i have also try to reset the Preferences but i was not able to get the prefrence to open , shift and alt didnt work 

                                             

                                            I cant understand why Adobe cant fix this simple problem ??

                                             

                                            i got this link from the forum Adobe Photoshop Lightroom Help | Lightroom Help is this the right help page? if so i can change lightroom_6.0.helpcfg   config to redirect to this but I am not sure is right place?  and what is the Swedish help page ?

                                            • 19. Re: Help not working in Lightroom CC.
                                              jbabacus Level 1

                                              I tried the fix mentioned in my previous post, and somehow it worked once, then broke again.

                                              My latest try is to edit Lightroom_6.0.helpcfg and replace the target URL. I am convinced that this is the file that is giving us trouble. You might compare a helpcfg file in another Adobe product that works properly and see what the differences are. Be sure you select your default language for both files, and MAKE A BACKUP of the original file in case this does not work.

                                              • 20. Re: Help not working in Lightroom CC.
                                                water bowl Level 1

                                                I just upgraded from LR 5 to LR 6. Of course, my luck, after a fresh installation the help file link does not work. So I followed all the google searches eventually to this topic. I see that there is an update that should have been installed immediately by LR when I installed it, dated July 2016. Some here are claiming this fixes the help file link problems so I decide to give it a try. I am very compliant about installing updates.

                                                 

                                                I go to Updates in LR and select that to start. It throws an error:

                                                Lightroom CC  / 6 – July 2016 Update.

                                                Installation failed. Error Code: U44M1P7

                                                 

                                                Then I start the google search on the error to figure out how to get the install of the update to take. I follow links and read all kinds of advice like uninstall and reinstall. The official Adobe website for LR updates does not even include an update for LR 6 only LR 5!

                                                 

                                                I eventually find a link for "Adobe Lightroom 6.6.1 + CC 2015.6.1 Update 7/25/16 Release 6.6.1" at a non-Adobe site:

                                                http://prodesigntools.com/adobe-cc-2015-updates-links-windows.html#lightroom

                                                 

                                                I run that installation but my System Info still says LT Ver 6.0, Version 6.1 after installing this update, not 6.6.1.

                                                 

                                                If I run Adobe Updates from inside LR 6, I still see that this July 2016 update is still waiting to be installed, although it is has continue to fail 3 times to successfully install the update.

                                                 

                                                After the fifth attempt to install the update via the LR Updates, it does finally install and now I see I have Lightroom Version 6.6.1. I guess I didn't push the button hard enough.

                                                 

                                                I've been at this for over an hour now. And the one thing I really needed was to have instant access to help files because I AM NEW TO LR6 AND WANT SOME HELP. However I STILL CAN'T GET TO Adobe Lightroom Help via the menu link!

                                                "can't find the server at community.stage.corp.adobe.com."

                                                 

                                                Seriously, this is like trying to install software on Win 95. How does Adobe get away with this kind of negligence?

                                                 

                                                I had a free hour to learn how to use the new features in LR. That time has disappeared trying to get to Abode help files via a simple link and install a simple update. Shame on Adobe for squelching creativity with mind numbing updates and failed help links. It is a no-brainer why I never chose to be yoked up to CC.

                                                 

                                                Is there any solution in the horizon by Adobe to fix the failed Help link??

                                                Matoca