0 Replies Latest reply on Apr 29, 2015 2:05 PM by mollym27598144

    Lightroom outdated for Mac 10.6.8?

    mollym27598144

      I have a Mac 10.6.8. This computer is not that old, and it is the desktop on which I do all of my photography work. My lightroom 3.6 now does not recognize the files from my SD card from my canon 5D. I have been told that there is no more tech support for Lightroom 3 AND that my computer is TOO OLD?! for an newer version of Lightroom? I paid $300 for my lightroom program less than 3 years ago. There is no reason why this product should now be useless.  I need to continue working on my computer. Please help.OUt