1 Reply Latest reply on May 1, 2015 2:06 PM by sprancej

    I can't successfully download Adobe Digital Editions on my PC

    wendellb53885892

      I have downloaded the installer, and invited it to "run", but then nothing happens. No further windows open. When I check the installer in my Downloads File I'm told that the file is "open"--I can't even delete it. I've tried downloading through Mozilla and Google Chrome--same result. Any suggestions?

       

      Wendell

        • 1. Re: I can't successfully download Adobe Digital Editions on my PC
          sprancej

          If the PC thinks the file is open, you can check in the Task Manager (if you know how to do that), I would suggest the easiest thing might be to reboot your computer.

          Then, open your downloads folder and reinstall the ADE program. 

           

          Once the ADE program is installed on your computer, you should plug in your Nook with a USB cable to the computer, and I think it automatically syncs. 

          I've been borrowing e-books from the library or getting e-books online for quite awhile with no issues, other than trying to manage the bookshelves.  I have no idea how that works.

           

          Anyway, once you've downloaded a book into ADE, you should easily be able to copy it to your device by first adding it to your library on the PC, then right click on the book and choose copy to device to get it on your Nook.

           

          I hope this helps!