2 Replies Latest reply on Jun 26, 2016 5:39 PM by Spiral Dancer

    Lightroom CC / 6 could not import this catalog because of an unknown error

    hesspoint

      Hi,

       

      I want to import an old Lightroom catalog into my current one and it always fails with "Lightroom could not import this catalog because of an unknown error"

       

      First off some details: Running Mac OS 10.10.3 with Lightroom CC 2015.0.1 (so the very latest). My main catalog is on my MacBooks main hard drive and all photos are on a thunderbolt external drive. The second catalog I try to import is on another external drive and uses the same folders for the pictures as the main catalog.

       

      But let me backup a bit so you know what I am dealing with: I have been using Lightroom 2 ages ago and migrated to Aperture at that time. What I did back then was to save all images from LR 2 as JPGs (to preserve all my edits done in LR for Aperture) and made pairs of the RAW and the edited JPG image in Aperture (a feature I already miss in LR).

      Due to obvious reasons I went back to Lightroom, just the day Lightroom 6 came out. Now what I did is use the "Import from Aperture" plugin to get everything into a new LR catalog. I kept all images in their place and in the same folder structure I had used with Aperture. The problem is that since I had those RAW/JPG pairs in Aperture with the JPG on top, LR imported the JPG's and no RAWs (I thought it would actually do both). That is for all the pictures that where coming from my initial LR times.

      Fortunately I kept my old LR 2 catalog from back then as a backup and figured that it would be best to just import that old catalog into my new one now (since I basically did not change anything on those pics in Aperture) to have all my RAW's back even with all the native edits from my old LR.

      So I upgraded my old LR 2 catalog to LR 6 on first open and cleaned it up, reconnected all images (100%!).

      In fact both catalogs are using the same folder structure on my external drive now. Mostly the images the 2 catalogs use are different (the one which was imported from Aperture uses the JPG and the one upgraded from LR 2 uses the RAW) but in some cases both catalog have the same pictures included.

       

      So all I want is that LR imports that old catalog into the new one and adds all pictures so I can later go through and throw away all the JPG's and keep the RAW's after I merged meta data like GPS, keywords etc (since I had worked on those in Aperture and they are now different in both libraries).

       

      In the settings of the import catalog wizard I select the following:

      - All folders in the list i.e. all photos selected

      - File handling: Add new photos without moving (since i want to keep them in my current folder structure just get them included in my catalog)

      - Replace: Metadata, develop settings and negative files

      - Checked the "Preserve old settings as visual copy" option (so that I can later carry over meta data to imported images)

      - Unchecked the "Replace non-raw only"

       

      When I run it it will display the error after 1 sec, so it won't even start.

       

      I played around with some of the settings in the import wizard e.g. uncheck the "preserve old settings..." option or selecting not all folders but no effect. I also tried exporting the "Export as catalog" for all images to create a new LR 6 catalog from scratch to rule out any LR 2 > 6 upgrading issues. Also placed both catalogs on my Mac hard drive to rule out external drive problems.

       

      If anyone has an idea what I could do to fix this I would be super grateful. Thanks in advance for helping a LR newbie (or at least long time non-user)!