4 Replies Latest reply on Jun 8, 2015 1:37 PM by g.bollmann

    Playing a timeline,  Class won't stay hidden - Bug

    g.bollmann Level 1

      Things like this have happened several times before with EA, but I've yet discovered how to hand fix rather than re-build. It is as if EA "catches a cold" or something on one detail or another.

       

      Flow:

      Inside a symbol, I want one element inside it to toggle on/off using a class toggle.

      A class is assigned to with the small [c] button. Super.

      I write code in another timeline to control the class. Goes great.

      I test the button. All good.

      Repeat for other classes/buttons. All separate, no overlaps. All good.

      Click a separate button that plays the symbol which also holds the class element ... all bad. Class won't stay hidden/shown.

          -There is no reference to the class in the other button. The only thing they share is that they class-element is inside the timeline which the button controls.

       

       

      Each class untoggles itself. Playing the timeline where the class item resides UNHIDES the class item

       

      Whatsmore, I can't add this instruction to Stage/Creationcomplete:  sym.$(".start").hide();

      No effect. (yes, I assigned the class to elements)

       

       

      * If the original state was set to hide, I can use the respective button to show it. Upon playing the timeline, the element goes to its initial state. OR

      If the original state was set to show, I can use the respective button to hide it. Upon playing the timeline, the element goes to its initial state.

      ** Yes, I confirm that the second button has Zero reference to the class within the code.


      What can I do? Has something gone astray in the code? Code splatter? Where can I clean it up?  /THX!