1 Reply Latest reply on May 6, 2015 1:15 AM by F. McLion

    what operating system do i need

    emmam84676442

      I have prepaid for lightroom and photoshop and when it came to using it said that my operating system was out of date for lightroom.  What do i need and how do i get it