0 Replies Latest reply on May 6, 2015 12:23 PM by gregk92755535

    I have Abobe Lightroom 4 and tried to install on my Mac but keep getting "The installation failed"  I have a Mac with OSX 10.6.8 which is the minimum requirement.  Not sure what else to do?

    gregk92755535

      I purchased Adobe Lightroom 4 and tried to install on my Mac computer (OSX 10.6.8) but keep getting "The installation failed."  I know there is a newer version but this product has not expired so I am wondering what I may need to do to get it installed?  There seems to be a technical issue.  Could use some help.