2 Replies Latest reply on May 7, 2015 11:35 AM by kdf30997636

    Just want to use Lightroom with my single computer using OS 10.6.8.  Can't seem to just purchase the software

    kdf30997636

      This is really frustrating.  I have been  using Lightroom for several years.  Unfortunately my computer crashed and I need to purchase the software again.  I have tried the iCloud plan but my computer is using 10.6.8 which doesn't support the iCloud plan.  I do not want to upgrade my platform which will affect my other software.  What should I do?