6 Replies Latest reply on May 15, 2015 7:14 PM by buffyh52134025

    I purchased the lightroom 6 dvd ..installed it for it to say "os does not meet the requirements.. it thinks i am runnning on vista .. but i have windows 7 service pack 1.. plz help

    buffyh52134025

      I have windows 7 service pack 1 but it it says i have vista.. i have downloaded updates and all.. plz help ty