0 Replies Latest reply on May 12, 2015 7:54 PM by sasham47897678

    Extesion Manager says I need last version of photoshop...

    sasham47897678

      Extesion Manager says I need last version of photoshop when I have the latest version. Spent an hour with Adobe support, they couldn't figure it out, I finally gave up. Hopefully someone figures it out.