3 Replies Latest reply on May 19, 2015 1:46 PM by Moertl

    Lightroom CC: problem with "mini-crashes"

    joergw25350918

      With the launch of Lightroom 6, I decided to join Creative Cloud and bought&installed Lightroom CC2015 (Lightroom 5 is still installed) on my Macbook Pro Retina (Late 2013, 2.6 GHz, 16GB RAM, SSD 512GB).

      The complete system is up to date.

       

      My problem: after working for a while, Lightroom CC produces what I would call "mini-crashes". The complete Lightroom surface vanishes for a split second and then Lightroom seems to "build itself back up" in terms of visibility and also seems to connect itself back to whatever it seems to look for (database, pictures, settings???? Can't tell, it's just and impression, since there is some sort of "loading-wheel" until Lightroom's surface becomes visible, again).

      This only happens in "develop" mode - haven't seen this happen in "browsing mode", yet. And: it seems to start, after I have edited a raw NEF in for example Silver Efex and reimported the picture as TIF. When trying to further "develop" that TIF, the "mini-crashes" start after touching any of the sliders, and then, even when doing nothing, the "mini-crashes" reappear by themselves over and over again.

       

      I did installe Lightroom CC without problems. The database-update seemed to work flawlessly (it took the filename of Lightroom 5 and added "-2" to it, so it looks like ".......-2.extension").

      I also tried, whether disableing the GPU-acceleration made any difference, but even with disabled GPU-acceleration, those "mini-crashes" happen. Also, I logged out and in of CC and restarted Lightroom - problem persists.

       

      Hope, that someone can point me to a solution...

        • 1. Re: Lightroom CC: problem with "mini-crashes"
          Ian Lyons MVP & Adobe Community Professional

          I don't believe what your describing is a crash per se. THat's not to say that there isn't a problem that needs further investigation, etc.

           

          You mentioned using Silver Efex. Does the problem  occur when working with images that haven't been edited in Silver Efex?

           

          Also, can you check if refreshing your Lightroom preference file stabilises things. Note that with Lr it is necessary that you hold down the Alt+Shift key when launching the application.

          • 2. Re: Lightroom CC: problem with "mini-crashes"
            joergw25350918 Level 1

            Ian, thanks for you answer. I have investigated the problem further.

             

            What I have - for the lack of other words - described as "mini-crashes" actually seem to be "refreshes" and "load-times" of Lightroom. If in develop-mode, you move a slider, the preview of the effect must be refreshed for every tiny move of the slider. With raw and jpg files, this seems to be no problem, since the problem does not occur.

            Now, when you do that with a TIF (for TIFs, I always use the option uncompressed), all over sudden, Lightroom seems not to be able to update the preview picture in the main, central area as fast as necessary. Preview gets greyed out, a black bar appears that says (next to a rotating sign) "Daten werden geladen" (data is loaded), and after that black bar disappears, the picture is visible, again (writing and loading development settings to/from the XMP???)

            What is strange about that problem is, that not only the preview picture is turning into a grey square, but also, sliders and navigation panes disappear. So, if you slowly drag a slider to visually approach the desired strength of an effect, all over sudden, picture and panes disappear and you can't go on. Only after the picture and the sliders reappear, you can go on trying to move the sliders to the desired strength.

            I never had that happen in Lightroom 5, so that behavior is completely new for me with Lightroom CC 2015.

             

            I tried to exclude external editors such as Silver Efex as the culprit by just exporting a picture as TIF using Lightroom's export function and reimporting the TIF back into Lightroom.

            Using any development slider on that very TIF, again introduced the problem, whereas working with the original RAW or JPG file, the problem was not present, still. So, the problem imho could be analyzed by looking at any difference in the development process of a TIF file (size of the file, handling of XMP sidecar file or whatever...)

             

            I then tried the following: is there a difference, when I point/click with the mouse to a certain position of any development-slider instead of dragging the slider to that position (in other words: the slider quickly JUMPS to a certain value rather that being dragged to that value)?  Most of the time, the preview was updated with no lag, and no "grey out effect" was visible.

             

            So my (possibly wrong) assumption after this experiment is, that Lightroom seems to be fast enough in showing the preview any applied change, when a new value is applied fast enough/straight away. But if you slowly MOVE a slider, preview&development "writing/reading/updating cycles" imho seem no to get around fast enough and produce that effect. As I said, I could be wrong with my assumption, it's just a thought, that came up by comparing the different behaviors of Lightroom...

             

            I then disabled GPU-acceleration, and the effect seemed to get a tad better, but at a certain point, began to appear, again. It seemed, as if the effect built up the longer I worked on developing a picture - as if some cashes were not flushed or some other sort of build-up was happening...

             

            I hope, that description is helpful in investigating the matter further - I have not reset my preferences file, yet, in the hope, that it won't be necessary to go through the hassle of restoring all settings...

            • 3. Re: Lightroom CC: problem with "mini-crashes"
              Moertl

              I have exactly the same problem with tif-files after editing them in Color Efex Pro. These "mini-crashes", as you called them, are really annoying. Hope there is a solution out there...