1 Reply Latest reply on May 15, 2015 12:52 AM by haxtbh

    SOS - Coldfusion stopped working today...

    kwfricke

      type Exception report

      message java.lang.NullPointerException

      description The server encountered an internal error that prevented it from fulfilling this request.

      exception

      javax.servlet.ServletException: java.lang.NullPointerException coldfusion.bootstrap.ClassloaderHelper.initServletClass(ClassloaderHelper.java:129) coldfusion.bootstrap.BootstrapServlet.init(BootstrapServlet.java:59) org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:501) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:950) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:422) org.apache.coyote.ajp.AjpProcessor.process(AjpProcessor.java:199) org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:607) org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:314) java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) java.lang.Thread.run(Thread.java:662) 

       

      root cause

      java.lang.NullPointerException coldfusion.CfmServlet.init(CfmServlet.java:97) coldfusion.bootstrap.ClassloaderHelper.initServletClass(ClassloaderHelper.java:121) coldfusion.bootstrap.BootstrapServlet.init(BootstrapServlet.java:59) org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:501) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:950) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:422) org.apache.coyote.ajp.AjpProcessor.process(AjpProcessor.java:199) org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:607) org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:314) java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) java.lang.Thread.run(Thread.java:662) 

       

      note The full stack trace of the root cause is available in the Apache Tomcat/7.0.54 logs.