2 Replies Latest reply on May 19, 2015 3:41 AM by ralfellis

    CS5.5 will not install - "eject disk image"

    ralfellis Level 1

      I am trying to reinstall InDesign.  But get an error message "Install cannot be opened. You should eject disk image."

      I have seen this message on a few forums, but no solution has been given.

       

      iMac OSX 10.7.5

       

      I don't have a problem with other installations, just this one.  For instance I ran the CS5.5 'patch', and that worked fine (except it had nothing to patch onto, of course).

       

      History:

      I did a reinstall of CS5.5.  But it still had a few issues (slow), so I thought I would do a complete uninstall-reinstall.  And now I get the error message above.

      So immediately before this problem, I had already done a CS5.5 install without any problems.  It was only after I did the uninstall, that the installation problems started.

      I also tried a 'CC clean', as the manual suggests, but there was nothing to clean.

       

      Another forum said try installing OSX 10.7.5, but I am already on OSX 10.7.5.

       

      I will try re-downloading the CS5.5 installation file again.  But since it takes 3 hours to download, I shall go to bed and let it download, and try to install it in the morning.

       

      BTW:

      Already checked disk permissions and disk repair  -  no problems.

      Already checked security permissions, and it is set to 'download from anywhere'.

       

      R

        • 1. Re: CS5.5 will not install - "eject disk image"
          ralfellis Level 1

          I have found a 'fix' that people say works  -  but I don't understand how to do this.  The guy said:

           

          Quote:

          OK, I seem to have found a fix for this. The problem seems to be that the installer gets "quarantined" because of an unrecognised certificate. This is marked against the file by an extended attribute. You need to clear the attribute to allow the installer to run again. The command for this is:

           

          xattr -c <pathname of the installer>

           

          The installer will run after this. It throws up a certificate error but you can tell the system to trust it. For some reason, the install ran completely clean after this and SoundFlower was there in the System Preferences - none of the "SoundFlower is not installed" malarky. The only things I am aware of having done differently this time are:

          1) Gatekeeper was disabled (as documented in my original posting)

          2) I copied the installer off the disc image on to my desktop and ran it from there

          3) I had restarted the machine just before running the installer

          I don't know whether any of those things made a difference, I mention them so that other folks who still have problems can try them.

           

          And the next guy said:

          I was trying to install a different application which has the same problem.

          "xattr -c <pathname of the installer>"

           

          Copying the file to desktop and running that command fixed the issue.

          Thanks whittm....

           

          ......................................................................

           

          But what do they mean by this?  I cannot find an installer for CS5.5, and if I did, how do I type this into the desktop?

           

          .

          • 2. Re: CS5.5 will not install - "eject disk image"
            ralfellis Level 1

            Hi.

             

            Solved my own problem.  The previous fix suggestion was correct - and you do this it 'Terminal Mode' which is in the Users Library.  Just type in:

             

            xattr -c /Users/******/Downloads/InDesign_7_5_LS1.dmg   (make sure that is the correct path to the correct installation file you are having problems with.)

             

            I did this twice, because once did nothing (spelling error?).

             

            Anyway, now Adobe InDesign is happily installing.

             

            Happy Days..... ;-)