2 Replies Latest reply on Jan 10, 2007 12:08 AM by hitparader61

    mx.transitions... ?

    popamonga
      Ok so here goes!

      I've been to every forum on AS that I could think of but still have not been able to find a solution to this.

      Here is a link to a FLA with a menu I'm working on.
      FLA --> [url]http://idisk.mac.com/jasoninch/Public/MENU_2.fla[/url]

      I'm using mx.transitions to have an alpha fade in/out when btn is clicked. That part of the script works fine.

      The problem comes with the "Info" and "View" btn's. The btn's only work on the initial Ad. They loose functionality because only the img0 alpha is effected and never really goes away. Therefor the user can't trigger the btn's because technically it's still in the way. I need away to have this go away or move so I can use the other btn's.

      It was suggested to me to use the ._visible property to achieve this. This is where I'm hung up.

      Cant get this AS to work correctly with my mx.transition script.

      Any help?

      Thanks > j
        • 1. Re: mx.transitions... ?
          popamonga Level 1
          Losing my mind!

          Can anyone advise?
          • 2. Re: mx.transitions... ?
            hitparader61 Level 1
            I don't think you can tween the _visible property, but you could just do a simple approach like this (just psuedo code here):

            if(movieClip._alpha<1){
            movieClip._visible=false
            };

            Or just set the enabled property to false on the initial click.

            Not sure if your buttons are true Flash buttons or movie clips that act as buttons (I did not download your file), but note that the enabled property on movie clips is a bit quirky, it only affects the, well, button-like functions of a movie clip. Works fine on true buttons though.