4 Replies Latest reply on Jan 19, 2007 9:54 AM by phil1021

    Flex 2.01 Update Problems

    phil1021 Level 1
      I TRIED installing the Flex 2.01 update. My configuration is Windows XP SP2 and I was running Flex Builder 2.0 (Educational Version). I downloaded the Windows update from here: http://www.adobe.com/support/documentation/en/flex/2/install.html (144 MB download).

      After the download completed, I ran the downloaded file (named flexbuilder2_201updater.exe) and went through the process of installing FlexBuilder 2.01. The installer needed to restart my computer before completing the process. After my computer restarted, I expected to see the installer tell me it was finished. But I never got any more messages from the installer.

      So, after waiting a few minutes, I ran Flex Builder. Still said 2.0 on the splash screen. I went to Help - Product Details and then clicked on Feature Details and saw that my Flex Builder 2 Core is 2.0.143459 and so is my Flex Builder 2 Standalone.

      However, when I try to open one of my Flex projects I get an error message!!! The MXML editor is not available!!!

      So I closed Flex Builder and ran the download again. Only now I get the message that an existing Flex Builder installation was not found and the installer will not run!!!

      I'm now going to try reinstalling the original software!!! I knew I should NOT have tried to do this on a Friday afternoon.

        • 1. Re: Flex 2.01 Update Problems
          Tony_Vines
          I had the same problem. I have the same configuration and the same Flex version. When I run the installer it ask to point to the Flex floder in C:\Programs\Adobe\Flex Builder 2. When I do it keeps telling me it is not there and will not let you progress any further in the installation wizard. I will postpone the update until I hear more.
          • 2. Re: Flex 2.01 Update Problems
            C. Agruss (Adobe) Level 3
            quote:

            Originally posted by: phil1021
            I TRIED installing the Flex 2.01 update. My configuration is Windows XP SP2 and I was running Flex Builder 2.0 (Educational Version). I downloaded the Windows update from here: http://www.adobe.com/support/documentation/en/flex/2/install.html (144 MB download).

            After the download completed, I ran the downloaded file (named flexbuilder2_201updater.exe) and went through the process of installing FlexBuilder 2.01. The installer needed to restart my computer before completing the process. After my computer restarted, I expected to see the installer tell me it was finished. But I never got any more messages from the installer.

            So, after waiting a few minutes, I ran Flex Builder. Still said 2.0 on the splash screen. I went to Help - Product Details and then clicked on Feature Details and saw that my Flex Builder 2 Core is 2.0.143459 and so is my Flex Builder 2 Standalone.

            However, when I try to open one of my Flex projects I get an error message!!! The MXML editor is not available!!!

            So I closed Flex Builder and ran the download again. Only now I get the message that an existing Flex Builder installation was not found and the installer will not run!!!

            I'm now going to try reinstalling the original software!!! I knew I should NOT have tried to do this on a Friday afternoon.




            Hi Phil,

            Thanks for alerting us to this problem, and I'm sorry it wasn't an easy update for you. We haven't seen this happen before, so want to gather more information if you can provide it. Can you post the installer logs resulting from the failed attempt, if you still have that folder available?

            Also, you mentioned that the installer prompted you to reboot in the middle of the update. That's highly unusual, and probably related to why it didn't go smoothly. Normally, the installer will only prompt for a reboot if you're trying to update a copy of Flex Builder that's still running, though the installer usually displays strong warning messages to quit the program before updating. Do you recall whether that was the case?

            Thanks,

            C. Agruss, Flex Builider Team

            • 3. Re: Flex 2.01 Update Problems
              C. Agruss (Adobe) Level 3
              quote:

              Originally posted by: Tony_Vines
              I had the same problem. I have the same configuration and the same Flex version. When I run the installer it ask to point to the Flex floder in C:\Programs\Adobe\Flex Builder 2. When I do it keeps telling me it is not there and will not let you progress any further in the installation wizard. I will postpone the update until I hear more.


              Hi Tony,

              I'm sorry it's not updating smoothly for you. When you say that you had the same problem, do you mean that the Updater ran fully at first, prompting for a reboot in the middle?

              Or did you experience any different symptoms? If you have the installer's log file available from the first update attempt, that might provide some clues.

              Thanks for any additional info you can provide,

              C. Agruss, Flex Builder Team
              • 4. Re: Flex 2.01 Update Problems
                phil1021 Level 1
                Chris:

                I do not have the installer logs from the failed attempt. Here is what I did to solve my problem.

                I reinstalled the original Flex 2 software from my CD.

                I downloaded again the update.

                I ran the update, but this time I unchecked the boxes that wanted to upgrade my Flash player. I figured since I already had the current version of the Flash Player, I did not need those.

                This time the update went fine, I was not asked to reboot. Flex 2.0.1 is working well on my computer now.

                Thanks for checking on me.

                Bruce